WIFI Password Length Artificially Limited

wifi

#1

The UI for entering WIFI passwords artificially limits the password length to 40 character. Because of this I cannot connect my GameShell to my WIFI and thus the internet. Does anyone know where this limitation is set? or how to get around this? Is there a way to activate WPS on the GameShell?


#2

@follower46


#3

Please update your launcher in the settings.
It should allow longer passwords now.


#4

Thank you @Petrakis and @follower46. Even though this a chicken and egg problem, I will figure out a way to get internet on my GameShell.


#5

oh snap… yeah, you can’t update without wifi… lol.
You can use usb-networking to copy over the latest launcher code.


#6

You can’t get usb eth working without wifi either


#7

As a temporary solution, you can setup most phones as a 4G Wifi Hotspot, to connect the GS and install updates. TinyCloud (SSH) would have to be done on the phone or connect your computer to the same hotspot to SSH.

LasVegas


#8

I have my wifi setup with an invisible ssid and no password for a myriad of silly reasons and so far this is the only thing I can’t connect to the network.


#9

I was able to update the launcher with access to a temporary SSID; however, the most recent update did not fix the issue. the launcher version is listed as stable 1.21 and gave me a unique git hash when I updated. I cannot find that git hash anywhere after the update to confirm If I have the version that was supposed to fit this issue. Is there a way to find this hash in the UI (without access to ssh)?


#10

They’ve rolled back the file that tells your clockworkPi to download 1.22, unfortunately. You have to follow the instructions in this thread to download the very latest launcher to make it work right now:

It’s not very simple, so I would avoid it unless you know what you’re doing with Linux.

One warning: if you do this, DON’T pick the “Switch to LauncherGo” option in the Launcher Settings menu, it will break startup of the Launcher on your device. Only way to fix is to mount the SD card on a Linux computer and edit ~cpi/.bashrc yourself, or to re-image the SD card and start over. Ask me how I know :wink: