Wont load launcher after skin updated

I have no clue what I did but, I tried to change a skin layout by switching to Redrum and for some reason it doesn’t want to load past the loading screen with the gameshell logo. I tried to switch it back the way the forum said it should be done but, still stuck at the same screen. help would be much appreciated please.

Hello there and welcome to the forums!
Uh oh, it may be that you have used a skin that was used for an OS prior to Clockwork OS 0.5. There is a significant change to the directory structure in the latest OS release. The skin basically mirrors the structure, providing references to icons to be used. When there are conflicts, or inconsistencies, it basically refuses to work.

I’m not sure which method you used according to the forum, but the proper way to return things to normal if you’re on 0.5 (and I am assuming here that you’re on 0.5) is to SSH into your gameshell (you can still SSH in while it’s stuck loading the launcher), and edit the file, /home/cpi/.gameshell_skin to contain /home/cpi/launcher/skin/default

That will at least allow you to reboot.

As for getting the skin to work, you will need to pretty much compare where every directory is in the skin relative to where you r files are. I can help, if you need; although I’ll need to know exactly which version of the OS you’re using. Some icons may be missing, since in 0.5, a few new things were introduced.

See how you go getting things back to normal first. Good luck!

(If you haven’t got something called “warehouse” in the launcher’s home menu, then you probably don’t have clockwork OS 0.5. It might be a worthwhile time investment to start over, and install it. The benefits far outweigh any legacy support from themes etc, or anything else.)

Oh boy. Wow. So I just looked at the post with the Redrum theme. Boy that one is ancient; dating back to before we had a proper theme switcher built into the system!
Back then, you would pretty much need to rewrite all of the stock files with alternative ones. This is scary. Things have changed a lot. We now have a skin chooser/changer.

Hmm how on earth can we make it easier for people to know if information is now obsolete? The place where skins go has completely changed. We no longer need to have the default skin directory over written. Argh! Hmm. So. My instructions might not work after all, assuming that you’ve completely overwritten the default skin with the obsolete Redrum skin. Give me a minute! I’ll upload a bunch of skins that I know are compatible, ie all of the ones from my system.

Okay. Here we go.

That link will take you to download two files: - This is what you will need to decompress, and copy the directory “default” to /home/cpi/launcher/skin, overwriting the existing default directory; assuming this is where you initially copied your Redrum skin files. Do this to get things running again. You can still SSH into your gameshell, even without the launcher fully loaded. - This contains in my opinions three of the more complete skins. Assuming you have OS 0.5, or even OS 0.4 with an updated launcher, you will have the directory /home/cpi/skins. You can copy each skin to this directory as you see fit.
Included is the stock OP1 alternative skin; just doctored to have all of the icons actually activated. A lot of them simply didn’t associate with anything, while others just didn’t have an icon.
Canisminor is a really nice softer sepia style palette that feels self contained and neat.
Greey is a darker theme, with colour icons that is fairly sharp and vibrant.
DEOT is one that I’m personally maintaining, heavily based on the DEOT version of the gameshell, with HEAPS of new icons.

That’s all the skins I deal with personally. If you want any other skins looked at, let me know. For the record, and again just my own personal opinion, the Redrum skin is fairly simplistic, and besides a great one to use in a darkroom, probably wouldn’t offer much more than the skins I’ve linked above.

Now. Just on a side note, usually the most basic way to fix things would be to do a git pull, ie by running this command:

cd ~/launcher
git pull

But depending on what OS you’re running, there could be a further indiscrepancy with files, ie the git launcher files are OS 0.5, and you could still be running 0.4. I think I read someone else have this same problem. And a further reason to upgrade to OS 0.5. It’s hard to be able to give definitive instuctions, not knowing exactly what your setup is.

1 Like

to start off i had just got it so, naturally i updated the system thru the in console update app to whatever was available. but i have seen the other post i think your referring to so, i will try that and hopefully one of the three things you have already mentioned will work.

Righto! Good to know where you are at! Thanks. So the update via the menu will only update the launcher files. The launcher files are basically the folder structure, files that give actions, and a few emulators. It doesn’t have updated drivers, kernels or general system level cleanups.

Although when you say you updated if via console, are you referring to the gameshell being the game console, or are you referring to using a console command prompt session fo perform a 0.4 -> 0.5 upgrade, or perhaps a full git pull && git reset --hard hashnumber

Which post are you saying you’ve seen that I’m referring to? I’ve made a lot of references to things, and just want to make sure that what you’ve seen is still current and applicable to the latest version of Clockwork OS. So much has changed lately that a lot of content is now obsolete.

If you can confirm if you have the warehouse icon, you can know if you have OS 0.5. I don’t know what OS new gameshells are shipped without nowadays. I also don’t know which version of the gameshell you’re using. It doesn’t really make a difference, unless you have the green DEOT version.

My DEOT version gameshell came with the DEOT gameshell OS, which is completely different to a standard gameshell OS 0.4, and besides the OS I’m maintaining, isn’t officially updated to the latest OS 0.5, thus won’t have warehouse. I got this gameshell after OS 0.5 was released.

If it does have warehouse, you’re good to go trying the above to restore your files. If it doesn’t, seriously cut your losses time wise, and download a version of OS 0.5. It’s something you’ll want to do sooner or later anyway, and will involved having to wipe your card. Do it before you invest too much time setting up all your files.

In fact, since you have only just started, even if you do have OS 0.5, it might be worthwhile to just flash a new image anyway. It will take less time than trying to troubleshoot a problem this early on.

There is technically a way to upgrade from 0.4 to 0.5, but that’s definitely for more advanced users, given how much trouble shooting after doing so you will need to do.

I believe there was someone who kept resetting after loading screen and would be stuck in a loop if I am not mistaken. Also just found ver. 5

Great. If you could find the post you’re referring to it would be most helpful. The reasons for it “resetting” (are you sure you mean reset? See below) could vary dramatically, depending on the circumstances.

Circumstance 1: the installation of the skin was before the skin system was implemented, where the skin ~/launcher/skin/default are modified, and the file ~/.gameshell_skin does not exist.

Circumstance 2: the skin chooser is implemented, the skins are stored in a different directory, namely ~/skins and ~/.gameshell_skin exists, where it needs to specify the correct location of the skin.

Circumstance 3: the skin in question has been installed to an incompatible location relative to the time it was released, or the directory structure of the icons precedes the mass change in directory structure to have the majority of menu items stored either in ~/launcher or ~/apps; as opposed to just being in the ~/ home directory.

I’m asking to see which solution you’re referring to in order to help you better. Sorry for asking for the same thing three times. :slight_smile: I actually never was referring to a thread, which is why I’m needing to know what you may have thought I was referring to. (Unless you count this thread you’re currently reading haha)

You mention that the thread you’re referring to has someone stuck in a loop. Are you referring to a boot loop? Because this is very different to just being stuck on a loading screen. That sounds more like a file system corruption. Can you verify if you’re experiencing a loop, and not a hang?

Was the thread you’re referring to the “resetting” referring to the user resetting their gameshell to recover, and was this via cutting the power, or a complete factory wipe/reset; or their gameshell automatically resetting itself?

The symptom I normally see with an incorrect/incompatible skin isn’t a reset or a loop. You initially said that you can’t load past the loading screen. Did you mean to say that it gets to the loading screen and resets?

Regarding finding v0.5 (not ver. 5 I assume?), are you referring to the official 0.5 image, my customised DEOT v2 0.5 image, The Arch Linux port, or the All in One 0.5 photo transfer 0.5 image? Or are you saying you just found out you’re on version 0.5? What is your plan of attack now? Are you writing a 0.5 image? Have you ascertained you’re on 0.5 and attempting to recover? Or maybe something different? Again, just wanting to know where you’re exactly at.

I believe it was this one “Gameshell keeps resetting” which was the closest to my own problem I will let you know the results when I get home though as I am at work currently

Also to be more exact yes the problem is I installed a skin red rum and it did not go over well I believe it said 1 .25 when I checked the browser settings or 1.24 and yes I did mean .05 virgin when I was referring to you what you were talking about I just finished reading the rest of your response

Thanks for getting back. Unfortunately the browser (??? I’m assuming you mean launcher) version makes a very big difference if it was 1.24 vs 1.25. And once you’re at 1.25 there’s no easy way to track the small updated version changes. So I’m just going to assume that you’re using the latest version.
And again, I’m guessing you mean OS v0.5 and not 0.05.

Can you provide a link to the exact post you’re following? Not just the thread name, since a lot of posts go on, with different instructions given, and different people post their varying symptoms.

Just asking again, are you dead set on 100% wanting to use red rum? If you are, you’ll need to do some serious editing if you want to make it work, along with installing it the correct way. That will involve needing to possibly generate a new config file.

To answer in order 1.) Yes launcher 2.) Yes OS v0. 5 3.) Here is the link Gameshell keeps resetting
And 4.) No I was just experimenting with the code but I did not realize it was outdated and I made a critical error thus setting me back for a moment. All in all asking as I can get it to boot the launcher again then I will consider it a win!( Bonus answer while referencing the linked forum I was looking for a way to find the updates for the launcher. While doing so I ran across this post and it seemed similar to my problem. Not exactly the same but, I believe you gave him an answer about updating and linked the update page through it that was why I referenced this post.)

Right. Okay so that post was completely different, where he couldn’t get up to the point where the launcher was even executed. That’s a hardware problem, and initialisation not completing.
In this case, yours is running. It’s just a matter of having enough information to fix it. Ha that’s why I was confused about what you were saying I was referring to! Now it adds up. Kind of. I still can’t find the link to the image you said I was referring to to update.

It sounds like you can recover, just replacing the contents of ~/launcher/skins/default, restoring them to normal; assuming that’s how you installed redrum.

Just double check the contents of ~/.gameshell_skin to make sure it has /home/cpi/launcher/skin/default

That should do it. Also consider backing up before doing any experiments with code, just in case you make any “critical errors” in future. It’s easy to do. I personally have 3 SD cards for the gameshell.

  1. 128GB - my day to day card filled with games - mostly doesn’t get fiddled with.
  2. 16GB - my sandbox test card - deliberately gets broken a lot, testing new things, compiling sources, trying stupid things etc. It’s where I simulate problems to help people.
  3. 16GB - my master image - after testing on card 2, and confirmed working, I write all the finalised changes to this card and have backup images based on this. It remains untouched, and is the source for my custom OS releases.

SD cards are so cheap, it’s worth just having them there for peace of mind.

1 Like

Lol sounds good :+1: I will make sure in the future to set aside one to play with

1 Like

Okay. I think I really messed up I tried to flash the sd card but it is telling me that the destination did not match when I used balenaEtcher. I tried to format it and re apply OS v0. 5 and now it’s stuck on the clockwork logo. I have tried to connect it via USB cable and it doesn’t turn on now

Right. So you’ve attempted to format it, using a fresh v0.5 image. I’m just going to assume you’re using a stock v0.5 image, although if you’re mainly gaming on the device, I highly recommend my image that I’m maintaining here

I’m assuming you’re using the same SD card as before. Some counterfeit cards are listed as some size, and sell for cheap; when they’re actually only a 2GB Card relabelled and with their header changed to say they’re 256GB or whatever.

Now for some trouble shooting.

  1. How are you going about flashing the image?
  2. What version of etcher are you using?
  3. What OS is your computer running?
  4. Did you decompress the file to have an .img file ready to write?
  5. Did you wait for the image to be fully written before ejecting the card?
  6. Did you eject the card properly?
  7. Did you have power connected to the gameshell during the initial boot up?
  8. Did you wait even during some black screens for the gameshell to properly initialise during the first boot? (Takes about 60 seconds, vs standard 30 second boot time)
  9. Have you tried doing it again?
  10. Have you checked to see a cable hasn’t come loose when you ejected the SD card? They are very prone to doing so.

Hopefully following that should get you up and running again.

If it still doesn’t start up after flashing a new image, check out this thread.
[Solved] Potentially dead mainboard?

Okay so surprising turn of events the image you sent me worked and it runs perfect thank you so much for everything

1 Like

Excellent. I tried to make that DEOT image a be all and end all image to solve everyone’s problems. In future if you have any problems, let me know you’re using that image, and I’ll know EXACTLY how it’s set up and will be able to help you faster.

Also before you do too much, I’m about to release a new image. I try to do one every 2 weeks. This new one looks really nice, so it will be worth the wait!

Follow the thread. It should be up within the next hour.

Edit: and 5 hours later - I forgot I needed to make/eat dinner. Ha. It will be up in 15 minutes. It’s uploading now. It will be worth the wait!

1 Like