Zelda Classic possible on gameshell?


#1

Hello there !

I hesitate a little before ordering a gameshell. The product seems really good with great potential.

However I wouldlike to know if it could possible to run a program named “Zelda Classic” on it. For those who do not know it is a program that allow to play higly customized zelda 1 games. A Zelda 1 game engine somehow.

https://www.zeldaclassic.com/

Assuming there exist a Linux version of the program, maybe it can run on the gameshell ? Can someone could test it and give some feedback, please ?

If it would be functional, it would play a big part in my decision-making.

Best


#2

As it is an opensource project, it can be build.

Does it will support the 320x240 screen? I can’t say, the website say nothing about requirements.

Looking at the sources, the default is 640x480, but nothing say it could not support a lower resolution.


#3

I just ran the game on Linux and the resolution can be configured in ag.cfg.

Will try to run Zelda Classic on the GameShell as soon as I have time…


#4

Would love to hear about the success of this!


#5

Thank you Oet !

I’m waiting for your feedback :wink:


#6

I tried to compile Zelda Classic on the GameShell, but the build scripts are not very ARM friendly. Even spent some time correcting stuff, but without success. Guess you need someone smarter than me. :slight_smile:

I also tried Solarus, an engine for running games based on The Legend of Zelda: A Link to the Past. There I have trouble setting the resolution and keys, but at least it runs on the GameShell.

Both engines are easy to install on a normal Linux PC, but I guess that won’t help you much. :smile:


#7

Thanks Oet!

Thank you for the time you spent trying to make it work. :slight_smile:

Too bad, it’s not yet tomorrow that I could play “Zelda Classic” in my restroom … :smile:

I know Solarus, it is also compatible with Retropie. It’s nice but less interesting.


#8

Hi all !

Sadly I have the final word from a ZC’s developper :confused:

It depends on what CPU the device uses. ZC can run on a portable Linux device with an i686 based / compatible CPU, but not on ARM, or other non i386-series chips. Our libs are architecturally locked at present–we don’t even support PPC anymore. ARM is out of the question. There’s no support for Allegro 4.4 on ARM at all, so you’d need to start there.


#9

The Zelda Classic README states:
"Do not try to link Zelda Classic against the standard 4.2.2 Allegro library. You must use the pre-built binaries, or the modified source."

So I ignored that. :slight_smile:

I installed all these Allegro 4.4 packages on the GameShell, so I guess some kind of Allegro support exists on ARM.

After removing the “-m32” flags and replacing pre-built i686 Allegro files by ARM Allegro files, the build script however still complained about missing some Allegro stuff.

Guess the only option is to play The Legend of Zelda using MAME or RetroArch…


#10

WTF? They are using an external and somewhat standard lib, but no let’s use a modified one just to annoy everyone?

Honestly, that’s a good reason to not use their thing.