clockworkpi

A04 won't boot after reflashing sd card

My a04 booted fine with the stock sd card, but it prompted me to upgrade ubuntu and once the process was finished the keyboard stopped working. I guess the upgrade broke the keyboard software. I was too lazy to plug in an external keyboard and try to fix it, so I just downloaded the a04 image and flashed it with ‘dd if=img of=/dev/sdcard && sync’, but when I try to boot from it I just get a green power light and I black screen. I read here that the first boot takes a while because it has to grow the file system but I’ve left it for several hours. I tried plugged in with batteries, plugged in without batteries, and unplugged, but no luck. Any ideas?

sdcards aren‘t perfect. Try to flash again and perhaps try another sdcard reader. /dev/sdcard makes me think it is an integrated reader in a notebook?

i did try reflashing it in between some of my attempts. it’s a usb sd card reader, it was really /dev/sd something. My image isn’t named img either, just filler names.

I used etcher instead of dd this time and it worked. Not sure why, I’ve always just used dd for images in the past

1 Like

When I switch an SD card between devices I perform two full zero wipes on them to ensure there won’t be any errors. This has greatly reduced how often a dd of an OS image will fail for me.

1 Like