Debugging A06 not booting?

Sorry if this is redundant but I finally had time to assemble my A06 I received a few weeks ago and don’t seem to be having lots of luck.

After assembly I pressed the power button and got a green light but nothing happened. I saw on here that there was a consensus that a batch of A06 units had bad/wrong SD card firmware so I reflashed from the DevTerm_A06_v0.1a.img file and tried again.

I noticed the original SD card had a “boot” FAT32 partition but the re-flashed card does not? I’m flashing from a Mac and Etcher wasn’t working so I did it with “DD” directly onto the SD device (/dev/disk4)

I’ve let it sit for several minutes (although the documentation says 60 seconds other people here have said 15 minutes so I’ve let it sit for that long with nothing happening so far.

Here is what appears to be working:
Power button turns Green. If I hold if for ~10 seconds it goes dim green and eventually out.
Small “beep” when plugging in power.

Everything else is up in the air.

I’ve seen some posts about broken/damaged backlights on the LCD panel and have tried using my phone flashlight to see if there’s anything on the display but haven’t had any luck. At what point in the boot process should the backlight turn on? That might be a clue?

I’ll try tearing it down and rebuilding it later but any ideas or clues are welcome.


Small update I took it apart and the heatsink on the A06 module was warm (not overly so) so I’m guessing that means something was working/running.
I reseated the display cable but it doesn’t sit flat as pictured in the documentation, is that an indication it’s not properly inserted? I can’t seem to get it any further in.


If you have a spare usb keyboard around you can try plug it in and hit capslock, and see if the LED turns on. This bisects the problem into Linux booting no display / Linux not booting.

Another way to confirm it is, if it boots but there’s no display, at least the backlight should be working (it’s independent from the LCD showing images), you’ll be able to notice a dim light that makes the screen “not so black”.

If you have a charge current meter you can also hook it up between dt and the charger. It typically draws about 0.5A@5V – anything less than 0.3A means that Linux is likely not booting.

Last but not least, connect the micro usb on the EXT board to your computer and use a serial terminal to see if there’s any output. The baudrate may be one of:

  • 1500000,8N1
  • 115200,8N1
    Even if you set a wrong baudrate, there will be at least some garbage text.
1 Like

Thank you. So should the backlight be lit from power on or does that happen if/when the kernel initializes it? I’m not getting any backlight from power on through power + 30 minutes.

Should the USB serial console be present at power on or only after boot works?


The backlight is initialized by the kernel driver. So if it’s not coming up then either Linux not booting, or there’s something wrong with the cable/panel.

The USB serial console on the other hand, is a hardware asset independent from Linux. You’ll be able to see what’s going on before the kernel boots :slight_smile: (das U-Boot messages)

Thanks. I think I need to find something that isn’t a Mac to try this out.

I’ve re-burned the SD card and verified it has the 4.something gig Linux partition (no FAT like it had when I first tried it before re-flashing)

I’ve connected 2 different microusb to the USB Uart port and while the D1 and D2 lights light up when the DevTerm is powered off, they are not on after power on (with the exception of a few blinks) and I don’t see any USB device (I’ve installed the CH34x drivers and rebooted multiple times)

At this point I figure I’m up against something apple specific or an issue with the USB dongle I’m using and will wait until I’m next in my office to try hooking it up to windows and/or linux to see if I have better luck.

Thank you for the help so fa.

Okay so it turns out my USB-C hub with the SD card reader in it was totally hosed and stopped working altogether after this.

I just got a new one and was able to burn the 0.1a card and boot no problem.

Thanks for you help! I look forward to coming up to speed and contributing to the community.

1 Like