After first use keyboard & mouse no longer works, how to recover?

Hello
after being stuck at fedex over a month, the devterm a06 finally arrived.
I assembled today without any problems.
First run was ok.
I changed my password, entered wifi password, tried browsing, tried external hdmi screen but did not manage to make it work, I ran the update, batteries are charging.

Then I had problems with next starts.
When I turned it off I had problems turning it on again.
I had to try many times until it finally started.
Also at some point it did no longer react to the keyboard and mouse ball.

I was wise enough that I recorded an image file of the SD card before I inserted it for the first time into devterm.

So now I recorded the image back to the SD card to revert any bad changes that I could have made.

And indeed after next start (without problems, starts the first time) I see the welcome message once again.
The problem is that the keyboard and mouse ball are still not working.
There is even no cursor on screen.
Even worse, external mouse and external keyboard (usb) also do not work.
I know that the mouse is powered because the highlight below turns on.
It reacts to the power button, the choice question appears but because of no input possibility I can not do anything with it.

I don’t understand this.
If I reverted the system on SD to the same state as before it should work exactly as first time, right?
Did I somehow damage it?
Did I somehow brick?

I cannot use it with keyboard and mouse (internal or external)
I cannot log in through ssh because:

  • I didn’t enable ssh server,
  • After restoring the SD card it no longer knows my wifi password

I have seen on the board a USB labeled “uart”.
Can I use it to log in?

How do I restore my devterm?

EDITED TO ADD:
I opened the case to be able to connect to that uart and experimentally verify if I can log in that way.
But after case opened, now the keyboard and mouse (internal and external) work again every time.
I suspect bad contact somewhere?
I expect that entire usb was wrong (internal keyboard is usb as well, right?)
I’m happy that it works again.
But how do I verify what was wrong?