clockworkpi

All emulators run awfully, are there any better gba and snes emulators?

I recently built a gameshell, but I’m very disappointed. The games look blurry and washed out (And even if you turn off filtering, it still looks bad). The few games that actually run tend to have glitchy sound and slowdowns, and games that use a 3d engine (For ex. Mario Kart and F-Zero Maximum Velocity) run awfully. I tried both gpsp+ and mgba, it’s the same thing. Is there anyway to improve this? Or, is this just because the gameshell can’t handle them?

I assume you are using RetroArch. The solution for me was to switch to the various standalone emulators that were posted on this forum (like PCSX-R, PocketSNES, Picodrive, gPSP and OhBoy).
With them I had zero issues (apart from tearing, but that seems to be a problem with the GS itself).

It’s a bit tricky at first if you are not used to the way the GS is set up, but there are a number of explanations on this forum that get you started. If you have more questions, let me know.

1 Like

Wait, most of those are already installed on the Gameshell. So you’re saying the ones on the site are different?

The ones that came pre-installed are RetroArch cores, not standalone emulators (if I’m not totally mistaken).

Alright, perfect! Glad it isn’t all a Gameshell issue. Now, how would I go about installing these new standalone ones? (Sorry, I’m new to this!)

This is how I did it (there are other ways). I used a Windows PC and Filezilla.

  1. Go to the github pages linked above and then to releases (if there are any) and download either the zip file (not the source code) or the single file that’s there
  2. If there is no release (as it is with PCSX-R) just download what’s in the depository
  3. Connect via Filezilla to your GS and do three things:
    a) Go to Games and make a folder for every emulator and put your roms in there
    b) Go to apps/emulators/ and upload the downloaded emulators there, each in a folder of its own. then do a right-click on all emulator files (not the folders, the files) and choose the last entry in the context menu to change the file permissions. They need to be able to be executed, or else they will crash whenever you open an emulator
    c) Go to Launcher/Menu/GameShell/ (should be something like that) and add either a folder with the name of the emulator and an action.script inside or an .sh file that contains the command “cd path/to/emulator” (insert actual path here) and a second line with “./emulator” (exchange “emulator” with the name of the emulator (not the .sh file you have downloaded)). Here’s how one of mine looks:
    grafik
    Some emulators require the action.config approach (I think from the listed above only PocketSNES) and some can be used without (as they allow to load roms from within the emulator). My action.config looks like this:

ROM=/home/cpi/games/SNES
ROM_SO=/home/cpi/apps/emulators/SNES/PocketSNES
EXT=sfc,SFC,smc,SMC
LAUNCHER=
TITLE=SNES Roms
SO_URL=https://github.com/cuu/emulators/raw/master/PocketSNES.zip

  1. Reload the UI and look if anything shows up. If yes, cool, if not, look if you put the action.script files in a folder and the .sh files in the right directory.

If you have any problems, let me know. I wrote this mostly from memory, so there might be some mistakes. But we’ll get there. :wink:

Thank you for the steps, so Gpsp works without a action.config?

If I’m not mistaken you can just execute the emulator and then choose a rom. Haven’t used it much, yet.

Oh and one thing about the OhBoy emulator: it crashes when you want to set the default rom directory (and always starts in the root directory). What you can do is change the config file and add the directory to the roms there (I think the config is in “.ohboy” or something like that).

Also most emulators create additional directories in the root folder once you executed it once, so be sure to do that.

1 Like

I tried installing the emulators, but I can’t find a standalone emulator core for mgba or pocketsnes. Also, almost every emulator has a large multitude of files on GitHub, and I don’t know which ones I’m picking because there are so many. I know how to put them on the system, but I can’t find the specific cores for the standalone Mgba, gpsp, and pocketsnesx do you have any DIRECT links to the cores I need? Sorry for any confusion! I’m new to this.

You have to go to release.

And then you can download the compiled emulator.

Unzip that and put in on your GS. (and don’t forget to change the file permissions as explained in one of my previous posts)

Ok tried these steps but it just ended up bricking my gameshell, so just deleted all the stuff that I added from this post, then it started working like normal again.
@Rebusmind

Ah, sorry to hear that. I’ve looked through the steps again and didn’t see any mistake. Maybe you can try adding one after the other and check if it’s still working. Let me know if you find a mistake in my steps.

No it’s fine, just read everything again, so for POCKET SNES, I just unzip the file, then how do I do the permissions part?

If you use Filezilla, you can just right-click and choose something like “file permissions”. If you use a command line, go to the directory where the emulator is and type “chmod +x PocketSNES”.
The thing about PocketSNES is that it doesn’t have the function to list available roms, so you have to use an action.config file (as you would do with any RetroArch core). You can see my action.config file in the big post.

1 Like

Alright sounds good, do I put the action.config with the launcher/menu/gameshell/PSNES?

@Rebusmind

Yes, as far as I know it has to be in a folder and should be named action.config.

1 Like

What would I do here to change permissions ?

@Rebusmind

EDIT: I clicked all to execute for each one, picodrive and Gpsp just boot me back to the menu and pocket snes just says invaid when I load a game

I give up, I’ll just use the retroarch ones

Just change that number to 755 (make sure to that for all files)

1 Like

After checking all execute boxes (or changing the number to 755) it should execute just fine. Do you use an action.config to execute it and does that use the correct path to your emulator?

!

image|690x350 !
image|690x197 !

image|415x500

I don’t know what I’m doing wrong, I did the file permissions, psnes says invaid when I load a rom, and the others don’t pop up

I individually put the emulators in each one, I unzipped all of them except for Gpsp

@Rebusmind