clockworkpi

All emulators run awfully, are there any better gba and snes emulators?

So PocketSNES opens but says it can’t load the rom? That’s strange. Have you tried different roms?

Ah, i just saw a mistake on my side. I wrote “action.script” in my last post, but it’s actually action.config. Sorry about that. So the action.config is the way to go for the PocketSNES.
Now what you called action.script in your first image should have the extension “.sh”. You can launch all emulators except PocketSNES via an sh file.
Sorry again about that confusion.

No worries thank you for the help, it actually wasn’t the ROMs I’m guessing it was the config

So is everything working now?

I’m fixing as we speak, I’ll report back…

EDIT: pocket snes works awesome

And Gpsp keeps booting me back to home

PicoDrive boots up but the only directory it takes me to is emulators

@Rebusmind

My gpsp emulator doesn’t have an extension, the file is only called “gpsp”. Where did you find the dms file?

Have you navigated in PicoDrive to your games once? I think it remembers the last directory (or you can look in the settings).

I got the Gpsp from your link… @Rebusmind
Should I just take of the dms?

This is what my picodrive settings have

The gpsp I took was also filed under release on github. It was a single file, not a zip.

Have you tried navigating in PicoDrive to your games, loading a game and then closing the emulator? Maybe it remembers the directory.

Yeah it wasn’t a zip but it still downloaded as that…

Got picodrive to work, it’s just Gpsp @Rebusmind

Can I see how your Gpsp.sh looks like?

I used the top file. Did you download that? If yes, maybe remove the extension (and check the file permissions again) and try again?

1 Like

Alright it boots up but this shows up, @Rebusmind

Alright nevermind it works perfectly, thank you for everything

1 Like

Congratulations! :smiley:

1 Like

Are you on OS 3? Do you think it worth staying on OS 4 due to all of it being a mess?

I can only say that I’ll be staying on 0.3 as I haven’t heard anything good about 0.4.

1 Like

Good news! I got the standalone emulators installed (Even though I still feel like the performance barely changed.) but snes Roms say “Invaid” when I try to load the engine.

Looks like it’s trying to download a core file, which isn’t needed. Have you checked if the path to the emulator file is correct in the action.config?

I don’t think I have. How would I check to see if it’s correct?

Also, I’m using standalone GPSP, but it runs badly. Is there any other standalone emulators, like mgba for example, and if there is, can someone provide a link?

There is no mgba standalone emulator, just Gpsp

You can open the action.config and check the directory (or did I misunderstand the question?).

There is one MGBA standalone emulator here:

But someone there said it doesn’t run well. I haven’t had any problems with gpsp. Which OS version are you on?