clockworkpi

Can't work on MAME

Ok! I will try FBA.
What version for FBA ‘s rom (0.78 or 0.81?)

Thank you for your reply

FBA is a bit less picky, so if you want a specific game you might want to try multiple sources, but I use mainly roms from:
FB Alpha 2016 RefSet v0.2.97.39
MAME 0.37b5

They hold much of what I need. Keep in mind that some games WILL run slow with FBA or MAME. But most run very well.

1 Like

Thank you so much!!
I will try it!

Where can download FB Alpha 2016 RefSet v0.2.97.39?
How to install it? Thank you.

In fact you should use FinalBurn Neo 0.2.97.44
And I can’t put a link here. I sent you a PM.

Hi @Lix

Can I grab any copy of FinalBurn Neo on the web?
MAME is working, but i suspect my bios files are in the wrong location.

Hullo! Welcome to the forums! :slight_smile:

http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/
It doesn’t matter where you put it. Just that you need to specify where it is in the action.config file.

1 Like

Hi @javelinface

Awesome, I am going to give that a try - thanks for the link.
I was messing about with MAME’s action.config file, but didn’t do the trick.

1 Like

The Cores or the Roms?
For the core look in here:
http://buildbot.libretro.com/nightly/linux/armhf/latest/fbneo_libretro.so.zip

You might want to look, here since it’s the ones made for the armv7-neon-hf, as opposed to just armhf. You’ll get cores that are optimised for all the instructions the gameshell is compatible with.
It’s from the same link I posted above, just a direct link to the file you want this time.

@javelinface @Lix

Ok, made those changes, set permissions to 775 (cpi) and created my action.config as below:

As well as created the folders as per the ROM and ROM_SO.
Think there might be something I missed :frowning:

Any thoughts?

Personally I set permissions to 755 but I might be wrong.
You know need the correct RomSet which is FinalBurn Neo 0.2.97.44
Then you will need to move bios from the RomSet to the GS Bios folder.
I cannot link to the romset but its out there, not super easy to find but it is still out there. :slight_smile:

2 Likes

I personally use chmod +x, making a file executable.

See here for more info.

That said, if you’re using an *.so file being run by the Retroarch launcher, you shouldn’t need to change any of the file’s modes.
For now, try and run it from Retroarch directly.
Unfortunately this means you may be potentially downloading another duplicate file in the place Retroarch defines your cores to be.
And argh. You will also possibly need to edit your Retroarch config to contain the buildbot URL I mentioned above.
After that, go into the online updater section of Retroarch, update core info files, then manage your cores.
The /home/cpi/apps/emulators/bios locations is only valid, if your Retroarch configuration is actually pointing to that directory in the config.
If you post up your Retroarch config file (use paste bin possibly) we can have a quick look at it.

Your action file explicitly has in the exlude line the neogeo.zip bios file. This is sometimes expected to be in the same directory as your Roms. Again, it all depends on your configuration. Possibly leave one copy of neogeo.zip in the same directory as your Roms.

Which version of clockwork OS are you using? Not that it makes much of a difference, but makes a great reference point to work with re: how things are set up.

1 Like

I feel bad that you guys are helping, really an amazing forum this.

On the about screen:
Launcher: stable 1.25
OS Image: V0.4
My /home/cpi/apps/emulators/bios looks as follows:
Annotation 2020-02-05 142137

@javelinface, I noticed on a previous post that you suggested upgrading to V0.5?
The setup is straight from the box :smiley:

1 Like

Haha! Don’t feel bad! That’s how people learn! Asking for help and giving help. :slight_smile:

Just in general, upgrading to clockwork OS 0.5 will save you having to do it later, after you have set things up. Might as well get it running on something you’ll be keeping for a while. It’s basically the same as 0.4, just with a working Lima/Mesa driver.

Right. So your bios is currently in the ~/apps/emulators/bios/ directory.
Try copying it to the same directory as your rom, ie ~/games/FBNeo/

So next thing to confirm. Is the fbneo_libretro.so in the ~/apps/emulators/ directory, and is it named exactly as you have typed it in the action.config file. Even down to capitalisation.

Which rom are you trying to run? Is it from the correct rom set? Some Roms just don’t run so you might have just gotten unlucky. You haven’t decompressed them or anything by chance? They should be kept as *.zip files, as expected by your action.config script.

Regarding Retroarch, have you made any modifications to the config file? If Retroarch doesn’t work, then you won’t have any luck making anything else work.
I have a pre made config file that I find works amazingly well, however it’s intended for a newer build of Retroarch 1.8.4, and depends upon the newer graphics drivers of clockwork os 0.5. Also try and load the rom from within Retroarch.

If you’re just using a stock config and haven’t touched it, while on 0.4, I should be able to flash a spare card and see where you’re coming from. But let me know first if you’re going to try using a newer image based on 0.5; just so I don’t waste too much of my time. ;).
I’ve got a custom image that I know for a fact should work, but possibly try the stock 0.5 first since that’s the official image.

Let me know what you decide. I’ll look into it tomorrow.

@javelinface again, thank you so much for all your help :smiley:

i am actually going to give your custom image a try - just need to get a spare card.

Tried your reccomendations, and got MAME to work - however not all games, but most of them. Rather sad that King of Fighters 98 isn’t working. :woozy_face: I have also noticed that some roms need a renaming, i.e. from caps to lowercase - forgot about that in linux.

Downloading the custom image now :smiley:

1 Like

Excellent that you got some working. Some games simply don’t work which kinda sucks.
Otherwise, as mentioned by someone else, try and get a rom set that’s made specifically for whatever core you have. For reference, my FB Alpha reference set is about 20GB. Chances are it’s archived on some site somewhere.

1 Like

FinalBurn Neo 0.2.97.44 ia avilable on the web, I looked two days ago.
KOF98 work under FBNeo

You really need MAME and FBNeo to get more games working.
Foe example In the Hunt (inthunt.zip) stutters in FBNeo but work well in MAME after using frame skip and lower audio quality…

WOW! that is huge! I should have bought a 64GB Micro SD! HAHA!

I noticed that too - it ran rather ok my end.

About to run the custom image @javelinface has put together - brilliant thread!!

1 Like