clockworkpi

D.E.O.T v0.4 - PCSX-R saves / states location

Hello everyone,

I own a D.E.O.T Gameshell on a stock v0.4 software.

During my update to v0.5, I’ve been struggling to find where the PCSX saves (and/or states) are saved. I’ve been playing a PSX game for like a week, both saving (through the game saving system) and state-saving. I now have an SD card which contains my v0.4 OS, and would like to transfer those saves to another SD card which have the latest software.

I saw a few threads here and there, but can’t find anything.
I’ve tried

/home/cpi/apps/emulators/
but nothing but cores in it. I have a bios folder, but no .pcsx folder.

Also tried to find some .psv, .srm files, or pcsx, state, save directory, without luck.

Also, I don’t know if I’ve been using the Retroarch PCSX or the standalone one.

Anyone found that save location yet?

Thanks for the help

Is a hidden folder, have you tried with ls -a ?

1 Like

Yep. There’s no hidden directory nor hidden files there.

I remember having a hard time finding them in the past.

Try here

/home/cpi/apps/Menu/Pcsx/.pcsx/sstates

1 Like

Alright, just found it.

Seems like it is located here for D.E.O.T Gameshells:
/home/cpi/launcher/sys.py/.pcsx/memcards/

1 Like

Nice,

find ~ -name “.pcsx”

Should be usfeul to find stuff, if you ever have to search for stuff again.

1 Like

Hang on. It shouldn’t be there. In 0.5, they changed the directory structure around.
The place that you’re specifying was the older 0.4 location for the files. They have since moved it to the first place, to facilitate having the bios directory align with where the rest of the bios images are kept.
Are you trying to back up your save files from a 0.4 image to use in a new installation? You will no doubt need to put them in the ~/apps/emulators/.pcsx/ directory.

Here’s both directories displayed. See the top for the file path.


There’s nothing in the path on the left, and the files you expect on the right.

Oh god. Please tell me you’re not using the DEOT v1+ image. That one was from last year. You’ll want to use the DEOT v2+ image if you are. Oh wait. Oops. I just realised you may not be using my custom DEOT image, but the stock DEOT image. Yep. My bad. How presumptuous. I just read the title of the thread.

Well the first thing you’ll want to do is possibly consider updating to either the stock 0.5 image, or perhaps my custom one if you want to retain the DEOT look. The DEOT stock 0.4 directory structure will be very different to most scripts and tutorials on the forum. For a start, the home user directory is named deot instead of cpi, which can break a lot of scripts. It’s also extremely outdated and as far as I’m aware isn’t maintained.

I am extremely surprised you managed to use the 0.5 update script and not break the installation! Double check to make sure your Lima drivers are actually working. Doing an apt-get upgrade to buster, which I think was a pre requisite to the update to 0.5 tends to break it. If you did do the upgrade to 0.5, the mmmm there could be some conflict of the pcsx file locations. They changed the directory location from 0.4 to 0.5.

I’m also assuming you’re referring to the standalone version. The Retroarch core uses completely different formats and locations. It also scales nicer, and doesn’t garble the text nearly as much. You would have needed to have set up your own action.config file if it was the Retroarch core.