Devterm A06 monitor problems

I just received my Devterm A06 last night night, put it together and found that I have nothing on the monitor. No backlight, no images if I shine a light onto the monitor, nothing. I let it sit for half an hour to see if it was expanding the filesystem or something like that, and still nothing. Yes I did email the developers last night but only been12 hours now so they may not have seen it yet.

But this makes me ask a question or two…

#1 will a Raspberry Pi DSI cable work, that may be my quickest way to get a get to see if I broke the included cable. I will check for breaks in the cable later tonight, didn’t have time last night.

#2 will this display work on a Pi4 in the DSI connection? I have a Pi4 that I could use to troubleshoot the display and cable if it is safe to do this.

Or should I download and write the latest OS image to the card to make sure I didn’t get a bad image?

I also tried using the HDMI connection, but I seem to recall that this may not be functional out of the box. Or it just didn’t work. I don’t have a Pi CM3 carrier board to try the Core module in, so no idea if this goes deeper than the display. I also do not have a CM3 to try in my Devterm, don’t know anyone that owns one.

I was powered by batteries that were charged in an external charger, I also tried batteries plus USB C, and just the USB C power. Also tried with just processor carrier board and core directly to display without extension board or battery holder. I did have green power LED so no power shorts.

Any help would be appreciated.

1 Like

first test if the system is running fine. plug in a USB keyboard and press the capslock/numlock to see if the indicators change.

does orange led ever turn on when you have usb-c connected?

I didn’t even think of plugging a keyboard in. Just tried it and nothing. So I downloaded the a06 image and flashed it with Etcher. Now I get display and the external keyboad Caps, and Num lock lights are working.

I guess it was just a bad image on the card and I should have done this last night.

As far as the orange LED, I did not get that and just figured it was from the batteries being fully charged on an external charger. I don’t have a USB C charger with me, so that will have to wait until later to check.

Thanks to everyone for the suggestions. I had the same issue – received my A-06 last week, assembled it this weekend…nothing except a green light (no batteries yet, Amazon is late). I took it all apart, yadda yadda, tried the HDMI, puzzled over the UART debugger (are there instructions anywhere for that?) to no avail. On the suggestion here I flashed a new SD card and it came up in a few seconds. Sounds like the new batch of machines has some QC problems with the SD cards.
Now it’s working and I’m trying to remember how to run Ubuntu.

Thanks Again

I would love to know if a Raspberry Pi DSI cable works. Where can I find out what type of cable the DevTerm uses for it’s screen?

EDIT: After looking at the cable and confirming with the main board schematics, I see the DevTerm does not use the 15-pin DSI/CSI cable like what the Raspberry Pi uses. I still don’t know if there is a name for this cable or not. The schematics hint at a 48-pin cable, but I didn’t count the pins to verify myself. I wonder if variations of it can be purchased elsewhere.

Too bad it isn’t the same as the RPi, that would have made things nicer for troubleshooting and for different builds.