Screen Displaying Only Noise On Boot

Just built my A06 DevTerm. Everything went fine. Cabling seems fine.

Booted it up with the included SD Card and sadly the screen is just displaying nonsense.

Some things I have tried:

  • Re-seating both sides of the display cable
  • Booting with the case open and jiggling the cable
  • Running on battery, battery + charger, charger only, multiple chargers
  • Flashing a fresh disk image onto the SD card

never meet before

how about double check the wires ,if they connected well
and if everything seems right still then

send email to

1 Like

As guu said, that really look like something is not correctly plugged. Try to reseat the cable to the screen, and the core module. Both carry critical signals that is they don’t transmit properly will led to (temporary) issues with the display.

Thanks both @guu and @Godzil . I have tried resetting the cable many times to no avail :frowning:

Hmmmm :confused:

Not sure what else to test, it can be a lot of different things. Though try to re image the SD card, just in case? Bad software could also cause that.

yeah, tried that as well, and get same result. At least I can be assured the re-imaging went fine because it causes the same exact pattern of noise each time. So it definitely leads me to thinking it’s a hardware issue. I just wish it was as simple as the cabling being loose, but that doesn’t seem to be the case :confused:

Just to close this out… I contacted ClockworkPi Support and after sending some pictures of the screen, they determined the best course of action was to send a new screen. It arrived very quickly, and once installed, the DevTerm booted up fine. Based on this, I would deduce it was in fact a hardware issue.

1 Like

So I received my original A04 with a screen that had a non-functioning backlight due to the flex cable being damaged, so I emailed Clockwork and they shipped out a replacement screen. In the meantime, I managed to fix the backlight on the original screen myself, and have been using that screen just fine. My replacement screen arrived, and it works just fine as well, until about 10 minutes or so of the DevTerm being on, and then it displays those same lines across the screen as shown in the OP. If I reboot, the screen works fine again for a little while and then does the same thing again. When I switch to my jerry-rigged screen, I have no issues.

1 Like