DevTerm screen seems "burned" after screen saver

1 Leave the DevTerm some period, and the screen is black out.
2 Wait some period, for example 1 hour.
3 Then wake up the screen, there some “ghost” pattern on the screen. The border of the screen is much brighter then center.

It seems the ghost pattern and bright border will fade out after dozens of minutes.
Does anyone have this problem? How can I avoid this annoying effects?

That may just be a limitation about the type of LCD used. This is sadly common with some modern IPS panel especially high DPI one.

Can you make a photo of it? Does it show mainly area where there is a high contrast change?

When I upgrading the Raspbian, I try to wake up the DevTerm, the screen is dead, displaying several colorful horizonal banners, this keep displayed until the upgrading is finished. The CPU tempreture is about more than 60°C。
After I reboot the system by remote ssh, the screen is ok, but the ghost image of horizonal banners last for a quit long period.
I cannot repeat the process, just try to take these photos, the border seems brighter than center:


As long as the ghost image does not stay, I would say, it is not alarming.

1 Like

I just built it now, and I have the same issue. To me, the screen is defective - but considering this is not a big company’s product, I don’t know if clockwork will exchange the screen. It’s too bad that the quality seems a bit less than I expected.

Just to be sure, you both have removed the plastic film on top of the screen right?

Yes, I removed the film.

2 Likes

A strange question. But my answer is it’s removed of course.

I did a few things today, and looking at the screen right before I shut it down just now – it seems ok. I did:
enabled sshd and VNC using raspi-config. Removed many s/w, changed background to grey color, and adjust brightness to 4. I VNC and ssh to it and ran/added/removed several things.

I noticed that the screen didn’t turn off it usually does when it’s not used for a while – I ignored this thinking it may be the VNC or ssh. Now I think something may have been changed.

Something else I noticed - in raspi-config, fan is not enabled. Nothing to do with the screen, but I wonder if this is how it should be.

(raspi-config have nothing to do with tthe fan in the devterm)