clockworkpi

DevTerm: top menu bar not showing

Hey there!

I have just assembled my freshly received DevTerm (RPI-CM3) but at startup, the top menu bar from the main interface does not show.
A white rectangle thing did flash a few times at the expected location of the bar at startup (and during the initial update phase), but disappeared after 5 seconds.
I ran the update, restarted the system a few times after a full power cycle, it looks operational (although I cannot do anything else than moving the bin icon on the desktop).


I manager to access the console with Ctrl+Alt+Fn+F1, did not see anything really exciting in log messages.

I usually use command line only so I am not familiar with window managers, and I don’t really know where I should be looking for error messages to understand what could be going on.
Unfortunately my device is not really usable without a menu bar here.
Would anyone have a tip to share with me?

Many thanks in advance!

1 Like

did you try to right click the background? that may open up a launcher menu box, not sure what desktop manager or WM the CM3 comes with

Thank you for your suggestion, it does open a menu indeed, I can access the menu bar parameter and ask for it to be shown at the bottom of the screen instead of top: after a reboot, the white bar flashes at the bottom of the screen, not the top, but that’s it :frowning:

I managed to get some insights from the log file “/home/pi/.cache/lxsession/LXDE-pi/run.log”
Which brought me to this thread:
https://www.raspberrypi.org/forums/viewtopic.php?t=148030
I am getting the exact same bug, unfortunately all 3 suggested solutions (that work for other users) are already implemented by default, so… I will have to look further.

Any recommandation would be welcome, I will update the thread if I find a solution!

Thanks

1 Like

right now I could not think of a good resolution for this issue, never happend to me during the whole development process

but just in case ,here is the cm3 rpi os image file

if the os continues to be buggy

1 Like

also
try this one

Thank you guu -
I did try the solution you submitted (removing lxpanel config file) - unfortunately the problem still happens.
I will try re-imaging the sdcard. Will keep you posted!
Thanks

No luck after re-imaging! :confused: Same issue…

https://www.raspberrypi.org/forums/viewtopic.php?t=191765

Thanks a lot - I ran into that as well, but it didn’t help.

But good news, I finally solved it.
How I found out :

  • Launched a terminal (Ctrl-Alt-T)
  • Launched “lxpanel” → I got a menu bar displayed, but a few error messages, and it was broken (mostly because the logo was missing for the main button).
  • Launched “lxpanel -p LXDE-pi” → I got this in the STDERR:
** Message: 17:56:17.285: x-terminal-emulator has very limited support, consider choose another terminal
grep: /home/pi/.config/lxpanel/LXDE-pi/panels/*: No such file or directory
** Message: 17:56:17.899: Connecting ...
** Message: 17:56:17.900: Status changed to down

** (lxpanel:7758): CRITICAL **: 17:56:17.901: dhcpcd_open: Resource temporarily unavailable
Unit pt-device-manager.service could not be found.

The missing service is interesting here:
I then ran apt install pt-devices, restarted the device, and now it works!

Thanks for your help!

8 Likes

@lawi I made an account just to thank you. Got mine in yesterday, put it together last night. I was just sitting down to figure out how to fix my missing menu bar problem and saw your post.

6 Likes

So I had this same problem for my first day of owning my DevTerm while I waited for my batteries to come in. Finally after installing the batteries, the top menu finally loaded.

I believe the battery monitor panel fails to init, thus causing the whole menu to fail to load.

TL-DR; If your menu isn’t loading, are you running without batteries? Try with batteries installed.

7 Likes

Thank you, I was running without batteries indeed!
Not sure if that was causing the issue, but it would make a lot of sense.
Thanks!

After a few days:

  • I would like to confirm DrRacoon was right, the problem is caused by using the DevTerm without batteries
  • Although installing the pt-devices package allows the menu bar to gets displayed without batteries - it also prevents the battery status indicator to be displayed, as Glbr_Hanson mentions in another thread (The battery/power indicator doesn't show up)

So I would advise readers of this thread not to install pt-devices as I recommended earlier. Just install batteries :slight_smile:

3 Likes