Does GameShell Actually Use FBTurbo?

os 0.4 does not contain modules folder for current kernel

mali-dp seem refer to mali display processor, the mali kernel parameter we spoken about last time refer to this,
as this page https://en.wikipedia.org/wiki/Mali_(GPU) it seem not related to mali 400 …

yes got last patch will be great \o/

Wait, does 0.4 still use the outdated Lima driver or the one in the mainline kernel?

don’t know, i need try my compiled 5.2, hope it will work with their dtb

as you said my kernel was made crash launcher cause of bluetooth, i just enable it & recompile
can be found here > http://gs.dread.fr/kernel/latest/

as with last image i cannot use hw acceleration

[    19.250] (II) AIGLX: Screen 0 is not DRI2 capable
[    20.856] (II) IGLX: Loaded and initialized swrast
[    20.856] (II) GLX: Initialized DRISWRAST GL provider for screen 0

checked 4.20 patch & 0.4 xorg log, enable some things like drm_sun4i but no luck for now
i’ll retry tomorow, it’s 4am Zzz

Sorry to reawaken an old thread, but after doing some testing with ptitSeb on the latest box86 fixes, he pointed out that my Gameshell seems to be running software OpenGL instead of using Lima, based on what it was producing in the logs. But I have it set to Lima, so I’m not sure what’s going on.

I was trying to find the old thread I remember where someone mentioned (perhaps you?) how to check in the system for whether Lima is active (not just in the launcher). Anyhow, I went ahead and ran glxgears and came up with this:

cpi@clockworkpi:~$ DISPLAY=:0 glxgears -info
GL_RENDERER = llvmpipe (LLVM 7.0, 128 bits)
GL_VERSION = 3.1 Mesa 18.3.6
GL_VENDOR = VMware, Inc.
GL_EXTENSIONS = GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_framebuffer_sRGB GL_ARB_multitexture GL_EXT_framebuffer_sRGB GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_ATI_fragment_shader GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_depth_clamp GL_NV_fog_distance GL_APPLE_packed_pixels GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_NV_primitive_restart GL_ARB_depth_clamp GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_compression_rgtc GL_ARB_texture_float GL_ARB_texture_rectangle GL_ATI_texture_compression_3dc GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_ATI_texture_mirror_once GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_gpu_program_parameters GL_EXT_texture_array GL_EXT_texture_compression_latc GL_EXT_texture_integer GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_map_buffer_range GL_ARB_texture_buffer_object GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_NV_conditional_render GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_seamless_cubemap_per_texture GL_AMD_shader_stencil_export GL_ARB_ES2_compatibility GL_ARB_blend_func_extended GL_ARB_compatibility GL_ARB_debug_output GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_stencil_export GL_ARB_shader_texture_lod GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_multisample GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_uniform_buffer_object GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_provoking_vertex GL_EXT_texture_snorm GL_MESA_texture_signed_rgba GL_ARB_draw_indirect GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_texture_compression_bptc GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_viewport_array GL_AMD_multi_draw_indirect GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ARB_base_instance GL_ARB_compressed_texture_pixel_storage GL_ARB_conservative_depth GL_ARB_internalformat_query GL_ARB_map_buffer_alignment GL_ARB_shading_language_420pack GL_ARB_shading_language_packing GL_ARB_texture_storage GL_ARB_transform_feedback_instanced GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_transform_feedback GL_AMD_shader_trinary_minmax GL_ARB_ES3_compatibility GL_ARB_arrays_of_arrays GL_ARB_clear_buffer_object GL_ARB_copy_image GL_ARB_explicit_uniform_location GL_ARB_fragment_layer_viewport GL_ARB_invalidate_subdata GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_stencil_texturing GL_ARB_texture_buffer_range GL_ARB_texture_query_levels GL_ARB_texture_storage_multisample GL_ARB_texture_view GL_ARB_vertex_attrib_binding GL_KHR_debug GL_KHR_texture_compression_astc_ldr GL_ARB_buffer_storage GL_ARB_clear_texture GL_ARB_enhanced_layouts GL_ARB_internalformat_query2 GL_ARB_multi_bind GL_ARB_seamless_cubemap_per_texture GL_ARB_texture_mirror_clamp_to_edge GL_ARB_texture_stencil8 GL_ARB_vertex_type_10f_11f_11f_rev GL_EXT_shader_integer_mix GL_ARB_clip_control GL_ARB_conditional_render_inverted GL_ARB_cull_distance GL_ARB_direct_state_access GL_ARB_get_texture_sub_image GL_ARB_pipeline_statistics_query GL_ARB_transform_feedback_overflow_query GL_EXT_polygon_offset_clamp GL_KHR_context_flush_control GL_KHR_no_error GL_KHR_texture_compression_astc_sliced_3d GL_MESA_shader_integer_functions GL_ARB_polygon_offset_clamp
VisualID 696, 0x2b8
306 frames in 5.0 seconds = 61.178 FPS
502 frames in 5.0 seconds = 100.210 FPS
501 frames in 5.0 seconds = 100.034 FPS
499 frames in 5.0 seconds = 99.753 FPS
496 frames in 5.0 seconds = 99.027 FPS
496 frames in 5.0 seconds = 99.140 FPS

The llvmpipe thing is what ptitSeb saw in the logs and why he suggested it was not using Lima after all. This is all on 0.5 official.

I’m wondering if I somehow accidentally clobbered my GL drivers in some of my testing and experimental builds? I think it’s unlikely but I’m wondering what others might get if they run glxgears -info
@javelinface, care to give that a try and share your results? Maybe it is using Lima and just reports it weird. But I’d like to be more certain. Thanks!

I haven’t tried anything, but before I forget, I remember where there was some discussion re: Lima, and if it’s being used etc. it’s around the posts and below. It’s essentially where proper Lima drivers on the gameshell were born. Haha.

Also there seemed to be some talk of apps erroneously using OpenGL over Lima here:

A question. Did you apt upgrade to Buster? I seem to always have problems with Lima and other things breaking, up to the point that Retroarch doesn’t work at times. Ironically this is a major upgrade step when using the 0.4-0.5 upgrade script.

I’ve wrecked my sleep pattern trying to get other stuff to work on the gameshell, so prrrobably should get some sleep for once! I’ll have a look tomorrow at what glxgears outputs. (I’ll be up for another 4 hours if I start tinkering now haha; you know how it be ;))

1 Like

before anything check your xorg server log file

if an update break the driver try uninstall mesa given from repository and reinstall manually the correct one

releasing a real debian package of mesa must be the solution for prevent this to append in future

if you don’t fear you can try arch edition of mesa (17 january git version) http://gs.dread.fr/arch/armv7h/mesa-lima-20.0.0_devel.1.d55573a-1-armv7h.pkg.tar.xz

best solution must be to manually compile it yourself, like in this pkgbuild https://github.com/r043v/GameShell-PKGBUILDs/blob/master/mesa-lima/PKGBUILD

so, basically :

git clone https://gitlab.freedesktop.org/mesa/mesa.git --depth 1
meson setup mesa _build \
       -D buildtype=release \
       -D prefix=/usr \
       -D sysconfdir=/etc \
       -D platforms=x11,drm,surfaceless \
       -D dri-drivers=[] \
       -D gallium-drivers=lima,kmsro,swrast \
       -D vulkan-drivers=[] \
       -D dri3=true \
       -D egl=true \
       -D gles1=true \
       -D gles2=true \
       -D glx=dri \
       -D libunwind=true \
       -D lmsensors=true \
       -D osmesa=gallium \
       -D shared-glapi=true \
       -D valgrind=false \
       -D tools=[]
       
    meson configure _build
    ninja  $NINJAFLAGS -C _build
    ninja  $NINJAFLAGS -C _build install
    ln -s /usr/lib/libGLX_mesa.so.0 /usr/lib/libGLX_indirect.so.0

according to mesa a pretty recent xorg server is also a need ( > 1.20 )

2 Likes

I did upgrade to buster. With all the stuff I’ve been installing, it seemed necessary, and I thought I remembered reading that with 0.5, upgrading worked and no longer broke Lima. I guess I was wrong. :frowning:

I haven’t had a chance yet to work through that first thread, but the link you provided seems to have plenty of answers. Digging through and figuring out what works and what doesn’t will be a bit of a chore though. And I’m pretty aure my Gameshell is not using Lima properly anymore, no matter what I pick in the launcher. Sounds like I’ll need to rebuild Mesa, though I saw mention in that thread of a prebuilt one that might work. I’m just hoping I won’t have to reflash my sd card and start over, because I’ve got a working build environment and other things I don’t want to lose, and starting over from scratch each time means I’m less likely to keep tinkering.

If I get It working and have a clear understanding of what I did to get there, I’ll try to write a new post with the information and steps I used. It’s unfortunate (and frustrating) that the Gameshell OS is so fragile and that the only documentation is scattered across buried posts in the forum. :frowning: I appreciate the help from you and @r043v though!

1 Like

@r043v can actually help you with knowledge! I’m but a retriever dog who has read all the posts in the forum, and can pull up information, and a willing and able guinea pig to test things on ;).
Also I know that feel re: losing the passion due to starting over. For that same reason, I’m constantly backing up images, and flashing spare SD cards to test things, before applying them to my main one.
Did you have spare SD cards to work with? I’m happy to throw a few bucks to a fellow game sheller, if money is tight. Your contributions are totally worth it!

I’ve got a spare card to test on, but I’m really hoping I can get things related to lima repaired on the current card. I’ve been using this one (256GB) to try lots of things, and build lots of things, and I’d probably want to archive as much as I could so I could move it to another card. All that is doable, but would just take a lot of time copying things back and forth (not to mention space to store it in the mean time).

I’m hoping I can figure it out, fix it, and continue to use this card as-is. But if not, I might take a break and try to archive and document as much stuff as I can. For instance, I could put some of the stuff I got working in the warehouse, and make notes of various things I tried to build that sort of worked or that didn’t work at all. (Related to that other thread, I actually did try to build Moonshell, but it seemed to require specific Raspberry Pi feature s we don’t have. It was also relatively easy to trick the script that runs Steamlink to try to run it on the Gameshell, but it also failed due to missing libraries. It might be possible to get running with the libbcm-host hacks mentioned elsewhere but I didn’t get that far, and I kind of doubt it would work anyway.)

Anyhow, it’s my own fault for using so much space for unfinished projects, but if I need to reinstall, I’ll want to take time and make sure I don’t lose anything I might regret. I’m not at that point yet though. I still need to see if I can figure out how to fix the Lima issue on this card.

I suppose on a positive note, it means that the box86 stuff that’s been running on my device will run even faster with Lima, once I get that working again.

If I do need to reflash, I’m also tempted to use the Arch variant @r043v put together. In some ways it sounds more stable, though I remember a post a while back listing some things it’s missing. I’ve more familiar with the Debian tools, but I wouldn’t be sad to see the launcher go, and it sounds like the fantasi launcher is more actively developed anyway. I’d just like to be able to do an update/upgrade (or whatever the Arch equivalent is) without having to worry I’ve destabilized the OS and broken the video drivers. :frowning:

I still love the Gameshell though, as it’s already met and exceeded the hopes I had for it. And it still offers a lot of potential, as I’ve already seen remarkable things running on it. I just wish it was a bit more reliable/stable in terms of software.

Speaking of software there’s another thread on here somewhere about someone launching only retroarch and using it as the only main software on the device. I think an emulator focused build like that would probably be a great benefit to folks who only got the Gameshell to play ROMs. It’s capable of so much more, but a Retroarch focused OS with few other bells and whistles might be more bulletproof and would probably generate fewer problems and questions from the folks who chose to use it. Just a thought. (It wouldn’t be for the tinkerers though.)

1 Like

So I looked at the xorg log file (which lives at /home/cpi/.local/share/xorg) and here’s what seems to be the relevant part:

[    30.754] (II) Module modesetting: vendor="X.Org Foundation"
[    30.754] 	compiled for 1.20.4, module version = 1.20.4
[    30.754] 	Module class: X.Org Video Driver
[    30.754] 	ABI class: X.Org Video Driver, version 24.0
[    30.755] (II) LoadModule: "fbdev"
[    30.755] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    30.774] (II) Module fbdev: vendor="X.Org Foundation"
[    30.774] 	compiled for 1.20.0, module version = 0.5.0
[    30.774] 	Module class: X.Org Video Driver
[    30.774] 	ABI class: X.Org Video Driver, version 24.0
[    30.774] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    30.774] (II) FBDEV: driver for framebuffer: fbdev
[    30.775] (II) modeset(0): using drv /dev/dri/card1
[    30.775] (WW) Falling back to old probe method for fbdev
[    30.775] (II) Loading sub module "fbdevhw"
[    30.775] (II) LoadModule: "fbdevhw"
[    30.775] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    30.781] (II) Module fbdevhw: vendor="X.Org Foundation"
[    30.781] 	compiled for 1.20.4, module version = 0.0.2
[    30.781] 	ABI class: X.Org Video Driver, version 24.0
[    30.782] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    30.782] (II) modeset(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    30.783] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[    30.783] (==) modeset(0): RGB weight 888
[    30.783] (==) modeset(0): Default visual is TrueColor
[    30.783] (II) Loading sub module "glamoregl"
[    30.783] (II) LoadModule: "glamoregl"
[    30.783] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    30.947] (II) Module glamoregl: vendor="X.Org Foundation"
[    30.948] 	compiled for 1.20.4, module version = 1.0.1
[    30.948] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    34.562] (II) modeset(0): Refusing to try glamor on llvmpipe
[    34.587] (EE) modeset(0): glamor initialization failed
[    34.587] (II) modeset(0): ShadowFB: preferred NO, enabled NO
[    34.594] (II) modeset(0): Output None-1 has no monitor section
[    34.595] (II) modeset(0): EDID for output None-1
[    34.595] (II) modeset(0): Printing probed modes for output None-1
[    34.596] (II) modeset(0): Modeline "320x240"x59.8    5.80  320 326 328 388  240 242 244 250 +hsync +vsync (14.9 kHz eP)
[    34.596] (II) modeset(0): Output None-1 connected
[    34.596] (II) modeset(0): Using exact sizes for initial modes
[    34.596] (II) modeset(0): Output None-1 using initial mode 320x240 +0+0
[    34.596] (==) modeset(0): Using gamma correction (1.0, 1.0, 1.0)
[    34.596] (==) modeset(0): DPI set to (96, 96)
[    34.596] (II) Loading sub module "fb"
[    34.596] (II) LoadModule: "fb"
[    34.605] (II) Loading /usr/lib/xorg/modules/libfb.so
[    34.610] (II) Module fb: vendor="X.Org Foundation"
[    34.610] 	compiled for 1.20.4, module version = 1.0.0
[    34.610] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    34.611] (II) UnloadModule: "fbdev"
[    34.611] (II) Unloading fbdev
[    34.611] (II) UnloadSubModule: "fbdevhw"

So I’m guessing lima is not being used. (I have it chosen in the launcher gui.)

I guess I’ll try rebuilding mesa. (That seems cleaner than taking the arch version?) I’ve already grabbed a lot of libraries for box86 stuff, but that’s been isolated – I’m not sure how comfortable I feel grabbing libraries and replacing core system components with them. :wink:

What packages should I remove from my system before installing mesa that I build? Is it the ones listed on the conflicts line in your script?
conflicts=('mesa' 'opencl-mesa' 'libva-mesa-driver' 'mesa-vdpau' 'libglvnd' )

Based on the xorg log, I think my version should be recent enough.

Is there anything else I’ll need to do or should the new mesa start picking up lima and supporting it when it’s installed? And while I honestly haven’t changed the setting from lima to fbturbo in 0.5 (except just in the past day to see if it could somehow turn lima back on), do you think whatever the launcher is doing will still allow me to switch if I update mesa? Or will I be on lima all the time? (Im not sure I care too much if I’m stuck in lima, but I figured it would be good to ask.)

Thanks!

EDIT:
I made progress on building mesa, but I hit a roadblock. There were quite a few dependencies I was missing, but I added them as meson stopped and threw errors. At least until it got here:
image
I’m not sure where I can get the “sensors” library. There are a number of packages listed when I do apt-cache search sensors |more and I don’t know which one I need, or if it even can be installed via package. So for now I’ve given up on rebuilding mesa.

However, the thread over here sent me down an interesting path:

I still have the lima drivers in place. And running dmesg|grep lima and cat /sys/class/drm/card0/device/uevent I get output that matches what was listed there, so lima is there are ready to go.

However, my ~/launcher/.xorg_lima.conf does NOT look like the one in that post – mine looks like this:

Section "Device"
        Identifier      "Allwinner A10/A13 FBDEV"
        Driver          "modesetting"
        Option          "fbdev" "/dev/fb0"

        Option          "SwapbuffersWait" "true"
EndSection

So instead of “lima” I have “modesetting”. So I just changed that to lima.

I also found this post:

And my /etc/ld.so.conf.d/00-arm-linux-gnueabihf.conf looked like this:

# Multiarch support
/lib/arm-linux-gnueabihf
/usr/lib/lima
/usr/lib/arm-linux-gnueabihf

I moved the lima line to the top since it sounds like that will cause it to get used before anything else.

I’ll reboot now and see what kind of mess I’ve made. :slight_smile:

1 Like

the mainline mesa debian just must not ship lima,
i don’t know if apt will let you uninstall mesa as it must be deps of some others packages
i think you may just recompile & install it, overwriting any other files

(for compile if it miss deps you may have to do sudo apt-get build-dep mesa

i used mainline arch linux arm mesa pkgbuild as base for gs one, the conflict list may contain gpu related (nvidia & co) who provide also mesa

1 Like

the .conf in your launcher folder must be the one set when you ask switch to lima from launcher,
that’s not mean it is outdated or the one used

[gs@gs ~]$ cat /etc/X11/xorg.conf.d/02-lima.conf 
Section "ServerFlags"
        Option  "AutoAddGPU" "off"
        Option "Debug" "dmabuf_capable"
EndSection

Section "OutputClass"
        Identifier "Lima"
        MatchDriver "sun4i-drm"
        Driver "modesetting"
        Option "PrimaryGPU" "true"
	Option "PageFlip" "off"
EndSection

you will also need rename or link /usr/lib/dri/sun4i-drm_dri.so replacing the - with an _

[gs@gs ~]$ ls -lha /usr/lib/dri/sun4i*.so
-rwxr-xr-x 21 root root 7.9M Jan 30 22:19 /usr/lib/dri/sun4i-drm_dri.so
lrwxrwxrwx  1 root root   16 Dec 15 14:41 /usr/lib/dri/sun4i_drm_dri.so -> sun4i-drm_dri.so
1 Like

Ok, thanks. I installed the dependencies (that was a lot easier that trying to figure it out when it encountered each error!)

I also reversed my changes to /etc/ld.so.conf.d/00-arm-linux-gnueabihf.conf and .xorg_lima.conf.

I don’t have this file:
cat: /etc/X11/xorg.conf.d/02-lima.conf: No such file or directory
So I should create it with the contents you posted?

I’ve kicked off the build setup again, and will try to get through the whole build process… (setup just completed, so here’s hoping the rest will too…)

1 Like

it could be another name but reside into /etc/X11/xorg.conf.d/

searching this particular file we found this git repo https://github.com/zhangn1985/lima_gpu_drv

So I should create it with the contents you posted?

from my previous tests, removing the file at all still boot & got lima enabled but there was a tiny perf less when try glxgear without vblank ( vblank_mode=0 glxgears

1 Like

I stupidly forgot to turn on my swap file, so I had to kill the build. I’ve rebooted, turned on swap, and have it going again (ninja $NINJAFLAGS -C _build). Looks like it’s going to take a while so I may just come back to it later when it’s done.

Hmm, this is all I have:
image
image
image
image
image

So I’m not sure where that lima configuration file is. :frowning:
Maybe it doesn’t exist anywhere, but I’m not sure how it would have gotten deleted? I might try grepping around for “Lima” in *.conf files across the entire system and see what I find.

I already seem to have sun4i_drm_dri.so in place (as a copy):
image

Maybe all I need to do to get lima working again is create that config file? Is that something an apt-get upgrade might have deleted?

Oops, I just realized those files I posted above are in a different directory. I don’t even have a /etc/X11/xorg.conf.d/ at all!
image

1 Like

if mesa-lima was manually installed into the system image upgrading mainline mesa will just let files without delete them

make a symbolic link is preferable as the link will everytime point on latest, a copy can be forgiven ^^

for speedup a bit the compilation process if you need to recompile it again you can remove wayland support from mesa configuration, it was enabled for me as i initially tried to have wayland instead of x11 in arch port

in clockworkos the conf may have been directly into /etc/xorg.conf ?

1 Like

My build completed. But install threw an error. Should I just put a sudo in front of this?
image

sudo did the trick…




image
No turning back now! :wink:

I checked the sun4i* files and one is now new, so that’s a good sign!
image
I just backed up the other one just in case, and then created the link.
image

And yes, it looks like you were right about the xorg.conf:
image
Although it kinda looks like the one in the launcher directory?

I’m not sure which one is being used. Should I change this one in /etc to match your config? Mine is missing both the ServerFlags section, and the “OutputClass” section and only has the “Device” section like the one in launcher. :frowning:

1 Like

yes :slight_smile:

my pkgbuild install in a dedicated directory to create after a real package, for real install you need admin right

1 Like

Cool, I think I’ve got everything done except for the config. See my edited post above.

Switching between fbturbo and lima in the launcher yields the exact same result for glxgears:
GL_RENDERER = llvmpipe (LLVM 7.0.1, 128 bits)
GL_VERSION = 3.1 Mesa 20.0.0-devel (git-8405e1bef0)
GL_VENDOR = VMware, Inc.

So it’s not switching anything.

I also tried updating the /etc/xorg.conf to use this:

Section "Device"
    Identifier "Lima"
    MatchDriver "sun4i-drm"
    Driver "modesetting"
    Option "PrimaryGPU" "true"
	Option "PageFlip" "off"
EndSection

But got the same result.

1 Like