Emulationstation on Gameshell

There

And this is the icon, made by me :

Emulationstation

5 Likes

great,did you use the v0.3 OS.i compiled the emulationstation with V0.3OS before . but lancher the screen blurred.

I’m sorry but how can I get the version of the OS ?

I tried to search in “About” section but there is only kernel version.

Are you sure you tried with the official git of EmulationSation ? On the master branch ?

Thank you!

This or Lakka is what I want to do with the GameShell, but with 0.3 the console is unusable for me. Waiting impatiently for an update for the lima driver.

One question. Why are you using the 4 years old ES from Aloshi instead of the updated one from the Retropie guys?

I tried it but I was unable to launch it.
The log said :
lvl0 error - file type unknown

I’ll try to compile on the video branch this evening

v0.3 OS see this clockworkOS v0.3 with GPU driver is available!
it is add the GPU driver and suport VSYNC . i compied emulationstation from Retropie some days ago with the v0.3 but it launch screen blurred.
and i post an issue to retropie forum
https://retropie.org.uk/forum/topic/21282/emulationstation-can-not-lauche/8
from the answer since the lima driver not stable.

lvl0 error - file type unknown means
you’re missing the resources folder in the right location - see:


1 Like

I’ve got v0.3 since I have the Lima driver available

You were right :wink:

Just need to put ~/EmulationStation/ressources into ~/.emulationstation/

I will update the wiki

did it launch no screen blurred

What do you mean by “blurred” ?

Did you install a TFT theme or you keeped the Carbon default theme ?

i keep the carbon default theme blurred like this image

Can’t see anything, sorry :grin:

Try to use a theme adapted to the Gameshell’s resolution

Which theme you recomend ?

You can try the GBZ’s. The links are on the wiki page

Pixel TFT is great too.

Minilumi

I can’t seem to get a build. After running cmake I got an error that said it couldn’t find the VLC library, so I installed it. I ran cmake again and it errored out again:

The source directory

/home/cpi/EmulationStation/external/pugixml

does not contain a CMakeLists.txt file.

I figured out cmake. Had to git clone the code for pugixml. I then got a bunch of errors about rapidjson so I installed rapidjson-dev

Running make now and crossing fingers :slight_smile:

EDIT

Got it installed. Here are the additional packages I had to install to get it to work, for anyone who may have had trouble like I did:

fonts-droid-fallback
libvlc5
libvlc-dev
rapidjson-dev

After I did the git clone for Emulationstation, I did “cd Emulationstation/external”
then “git clone https://github.com/zeux/pugixml.git” before running cmake.

Now just having trouble with the themes, but that will have to wait until tomorrow.

Yes that’s my fault, I have to corrected the wiki.

You must do a recursive git clone

1 Like

No worries, your tutorial was very helpful. Thank you.

Question about themes: How would I get ES to load one? I ran git clone for the dark theme you provided a link for but I had to “sudo mkdir” for the two folders under /etc folder. I then ran emulationstation but I am not able to read anything on the screen. Pressing start or select causes ES to exit. All other buttons do nothing.

If so I’m pretty sure you have a problem with your system.cfg.

Be sure you don’t have any typo or something wrong in this file.

Also there must be at least one rom in the roms directory of a system. Otherwise, this one is ignored.

If ES is not able to recognize at least one system it’s stopped.