Enabling HDMI out on CPI3.1

I just got my new CPI 3.1 board and installed it. I bought a mini-HDMI to HDMI adapter, but can’t seem to get any output from it. I have tried plugging it into a monitor, and tried using a PC video capture device. Currently I’m using a Magewell USB capture device to pass the HDMI to USB3 on my laptop. So the setup looks like this…

CPI -> miniHDMI to HDMI adapter -> HDMI cable -> Magewell USB capture -> USB cable -> Laptop

On the laptop I’m running OBS to capture the video from the CPI. Unfortunately it always shows as “No signal”. The magewell works fine on any other HDMI content.

I tried sshing to the CPI and had a look at the xrandr output, in case there was a second display shown, but there isn’t.

cpi@clockworkpi:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 320 x 240, maximum 320 x 240
default connected 320x240+0+0 0mm x 0mm
   320x240        0.00* 

What do I need to do to enable the HDMI out on the CPI?

have you ever tried with clockworkpios v0.21?

I had not! Thanks for the link, will try it.

1 Like

I tried the V0.21, the hdmi not working

what is your situation?

if you are in v0.21

plugin in micro hdmi

and reboot

does hdmi finally work for you ?