Full screen in Various Emulators


#1

Hey there, I can’t seem to get any emulator to display in full screen. They all sit at there various resolutions with scaling up or anything.

I’ve looked through some other threads which touch on this, but none of the solutions work for me.

Any advice?

Thanks!


#2

some screenshots please


#3

Your Retroarch config file is messed up! The easiest way to fix it is to SSH into your Gameshell and enter the following:

cp ~/.config/retroarch/retroarch.cfg.bak ~/.config/retroarch/retroarch.cfg

then go to Settings->Buttons Layout and press the key for “UpdateRetroArch”.

LasVegas


#4

Will that reset everything so I would need to set it all up again? For instance Key bindings etc as well?


#5

Here are my current settings, they seem to check out with what others have, but maybe I’m missing something.


#6

well, I think it’s better to restore retroarch.cfg

copy this retroarch.cfg into /home/cpi/.config/retroarch in you GS

it will fix


#7

Ok great, I will do this. Just again sorry, will it reset everything?


#8

Just reset retroarch only

And I am not sure if you know that is ,launcher also supports custom config for every type of Emulator by put a retroarch-local.cfg into
/home/cpi/apps/launcher/Menu/GameShell/20_Retro\ Games/[MGBA,MAME,etc...]


#9

Ok, I think I understand. Thanks for your help. I’ll give it ago!


#10

All works now, thankyou!


#11

The Settings->Buttons Layout and press the key for “UpdateRetroArch” sets up the proper Key Bindings for your layout. You would probably want to go in a tweak your settings for your personal preferences afterward.


#12

Just so you know, the option that was making your screens small is “Integer scale”. That makes the resolution only scale if it’s 2x, 3x, etc… Entire/full/integer numbers (not 1.8 or 2.243)! It must be set to off so that it will scale even if it doesn’t reach an integer.


#13

Ah ok, that’s interesting. I’ll keep that in mind Thankyou!