gpSP not working, even when setting up gba_bios.bin

Hey there.

Unfortunately, I have sound and performance issues with mGBA so I want to try gpSP. I’ve read of users here who got it working, but no matter what I do, I can’t get it to work. At first, it would crash and say “Failed to load content”. Then, I set up my “system” folder, put the gba_bios there, and told Retroarch about it. Now it loads and then crashes back to the launcher without message. I’ve also tried putting the bios in the rom folder with no success.

I have Retroarch 1.7.5, gpSP 0.91 and I’m running the config as the Retroarch Megathread suggests.


Same issue :no_mouth:

I’ve tried building it from three or four different GITs as well. No avail. Would really like some help here.


Found this. Gonna try and build with it after work. Wish me luck!

Here you gooooo

1 Like

Thanks man! I’ll try it as soon as I get home!!

:smiley: :smiley: Thanks, but how to use it? retroarch still said “failed to load content”

You need the gba bios file, and I can’t link that to you here. Google will help tho.

Once you find it, make sure it’s name is “gba_bios.bin”

Perhaps this is also helpfull… you need to configure some stuff…

1 Like

I have this file and put it into the same directory with gba game rom, but it still crash.

It has to be in the BIOS folder.

(In retroarch, under SETTINGS > DIRECTORY make sure the system folder you select is the folder with the bios in it )

1 Like

Yup Micro007 was right, the problem putting it in the retroarch default default .config directory is pain. but again we can be easily create a new directory under cpi home directoryand put all the bios file which is easier.
or you can add a config to point the gba bios directory on your action.config

1 Like

I just made a folder called “BIOS” in /home/CPI/

and I point it there