Has anyone tried to get OpenBOR to work?


#1

OpenBOR is an opensource game engine for lots of classic beat em ups, there are quite a few really cool mods out for it, and I wonder if anyone has tried getting it to work on the GameShell yet.
It has a Linux version, but honestly I’m clueless about Linux.


#2

I just tried to compile this. Seems it does not work out-of-the-box. It needs hacking to get this working on ARM-boards like the GameShell.

Apparently they already hacked something for the Raspberry Pi:


#3

Thank you for looking into this. I’m a complete novice with this stuff. I’m assuming the RetroPie link here might not work on the GameShell, right? or would I be able to write my own action.config, like I did before to add SNES and Genesis to the RetroGames folder?


#4

I am an idiot. I can compile the Raspberry Pi version I just sent you on the GameShell. However, when I want to start a game I get a segmentation fault… But I haven’t got any games either.


#5

Now that OpenBor runs on the GameShell, I get errors loading fonts and loading level orders when I want to start some random downloaded game.


#6

Wow! It’s great to hear that you’ve started tinkering with it, there are a lot of great games out there for the engine.
Which game are you trying to get to run? since most are fan-made, there could be an issue with the .pak itself.


#7

I tried AVP and also Asterix. Problem is that they give the SAME errors. Can you send me a link of a game you want to try? I can try it out.


#8

oh are you trying the
I think to find the .pak file to use with GameShell, extract the zip and take the .pak from the Pak folder, everything else is just the windows build of the engine


#9

I think I understand why all those games don’t run.
The OpenBOR on Linux has a very strict naming system.

Every filename in the pak:

  1. needs to be lowercase
  2. we allow only A-Z,a-z,0-9,-_. in filenames to prevent mod breakage!

To correct this they added an unpacking and (re)packing executable, but all those games I tried (including yours) have weird filenames in the pak, like spaces and other characters.


#10

ahhh… simple renaming them won’t fix it? luckily they .pak files can be named anything with openBOR from what i understand

Oh wait, I think i understand, Linux needs to extract each .pak right, so even files within it need to follow those naming standards… yikes.


#11

Yes. Maybe they made the rules stricter to be multi-platform? Now it makes a bit more sense some paks are meant for Windows or Mac.


#12

So I:

  • Unpacked ‘Mortal Kombat Outworld Assassins.PAK’
  • Renamed all files to allowed format.
  • Repacked to a pak file.

It actually started until I hit some memory problems.

So, yes OpenBOR “kind of” works.


#13

@detourne It is against forum rules to post links to copyrighted materials or sites that supply them. It would be appropriate to suggest a Google search for such material.


#14

Thanks for the tip lasvegas, i’ll remove the links, but since they are fanmade games, I believe they would be considered transformative works and be subject to fair use.


#15

Depending on the license(or if they dont have license, they are still liable to copyright) and derivative works void the copyright if the license doesnt allow it or if they are unlicensed.