Help requested: frozen OS UI after failed operating system upgrade

I tried to upgrade the operating system last night from 20.1 to 20.6, and it eventually timed out. This morning, I rebooted the host, and when it comes back, the OS UI is basically frozen. Doesn’t respond to mouse or keyboard input. When I press the on/off button, it brings up the “Log out cpi” dialog box (with log out, restart, shutdown, switch user options),but the keyboard and mouse still don’t work.

Would appreciate any help on how to proceed. Happy to do a factory reset if needed be.

Thanks in advance!

I’m not sure entirely what state the timeout would leave it in, and how that affects the mouse/keyboard, but the end solution is to try and finish the update.

There are three ideas I have you can try:

  1. Try pressing Ctrl + Alt + Fn + 1 to get a console session. It’s possible this will work if the problem is something about the Xorg input drivers and not the entire system.

  2. Log in via SSH.

    a. If you haven’t enabled it yet, you may need to plug the SD card into another Linux machine to make the changes necessary to enable it.
    b. Similarly, if you don’t connect to Wifi until after login, you may need to do similar changes to connect to your Wifi on login. I only know how to do this offhand in the GUI, but can help you look it up if needed. Another option here is a USB Ethernet adapter if you have one lying around.

  3. Connect via the serial terminal. I haven’t tried this at all, but I think there are some posts in the forums about getting this going.

Once you get into the machine via one of the above methods, you should just need to do:

$ sudo apt update
$ sudo apt upgrade
$ sudo apt full-upgrade

Thank you!

Ctrl+Alt+Fn+1 sadly isn’t bringing up a terminal. It looks like I’m not getting any keyboard input at all.

For #2a, my device is on network, and I’m able to ping it, but I haven’t enabled remote ssh into it, so when I ssh into it I get a “ssh: connect to host port 22: Connection refused”. :confused:

Is there a third way --boot to the os and go right into shell? I tried holding down shift and esc during the boot sequence, but it went right into the OS UI both times.

Sorry, I’m not aware of a way. If you don’t have a Linux machine, you can always just boot from a live Linux USB drive and then you can use that session to read and modify the card.

Unfortunately, I forget the exact steps needed to enable SSH. It doesn’t seem to be documented on the wiki. I might need to flash a spare SD card to check if you can’t figure it out.

1 Like

Ah. A bit of searching and I found this thread about enabling SSH. So, if you mount the SD card in another Linux system, try removing etc/ssh/sshd_not_to_be_run and see if that’s enough.

If that’s not enough, I can also check for you how to do a systemd enable from another system by just changing the file system.

EDIT: Just tested doing that only without touching the systemd commands, and SSH seems to be up on a fresh install.


have you checked plugin in a usb keyboard to see if maybe the keyboard stopped working or if the os hangs?

1 Like

Good idea with the USB keyboard! It totally worked. Going to try to finish the OS install now.

1 Like

Looks like I’m back in black – after the full upgrade and reboot, keyboard and trackball are working again. Thank you @zerker and @stefan ! Gonna go enable remote ssh now in case I ever get locked out again :slight_smile:

1 Like

@zerker , that thread you linked to above worked like a charm for enabling ssh into the devterm. :bowing_man:

1 Like