How can I install, configure and run DOS games?

Does any have any interest in trying to get “The Oregon Trail” working with DosBox? Seems like it would be cool

Hi, can you share each of the Gameshell + Lightkey, buttons codes for DosBox?
Ex. X = Key18
Y = Key248…

If not, how can you figure which key does what and add it to the mapper file?
The reason I am asking this is, I want to add a jump key to your mapper file but can’t figure out each of the GameShell button corresponding codes…

Not sure if my question make sense. lol

here is SDL keycode for gameshell, yet never plug lightkey so don’t get them =)

#define ka 106 // j
#define kb 107 // k
#define kx 117 // u
#define ky 105 // i
#define kfna 104 // h
#define kfnb 108 // l
#define kfnx 121 // y
#define kfny 111 // o
#define kselect 32 // space
#define kfnselect 269 // -
#define kmenu 27 // escape
#define kfnmenu 8 // backspace
#define kstart 13  // return
#define kfnstart 270 // +
#define klk1 278 // home
#define klk2 280 // pageup
#define klk4 281 // pagedown
#define klk5 279 // end
#define kfnlk1 kfna
#define kfnlk2 kfnx
#define kfnlk4 kfny
#define kfnlk5 kfnb
#define kleft 276 // left
#define kup 273 // up
#define kright 275 // right
#define kdown 274 // down

for missing keys you may check
and compare them with

Wow thanks!
Is “kfn” key with function like the Shift key combo?

yes sorry in my mind shift button is fn %)

Great thanks m8! :slight_smile:
This will save me some times.

i complete them, hope is right codes

Well I am stuck again…
I try to play Star Wars Dark Forces and I need a button to be used as Spacebar for Jumps
In my file its already set as key_space “key 105” “key 32” so Y or SELECT should jump right?
Its not…

if you just run dosbox for dos prompt does it print space ?

I was hoping to get ES II Daggerfall running anyone tried it?

I am running DosBox SVN Vanilla so I created a blank and launched it.
And yes, Y is registering as spacebar in prompt.
I will try another source since the problem seems to be gameside.

UPDATE: So I tried 3 different sources and I still can’t jump.
UPDATE2: Jump is not Spacebar, its X…lol So now I can jump! The manual is wrong.
So: key_x “key 120” "key 117"

I tried Daggerfall, can’t load at all.
You can try different sources.

Anyone figures out the problem with soundblaster setting for DOS games?
Why my game just got Sound Effect but without any BGM?

And I have a question about mapping keyboard)
in .dosbox after firs launch I have file dosbox-0.74-2.conf
So I took mapper file from here changed name to and edited to my preferences. But it doesn’t work. Maybe I’m missing something? Maybe I need to “turn on” this layout in config file or something?

Got it: need to change path to file in dosbox-0.74-2.conf because it leads to older version name and not to

1 Like

If you do have sound effects in the game, the sound settings for DosBox seem alright. Do you have music in other games?

How can i do that?, i don’t have the remap file, how can i configure the buttons to play?

The mapper is meant to configure by mouse:

If you click on a button with your mouse, you can see in the lower left corner with which event it is associated (EVENT) and to what events it is currently bound.

The mapper does not seem to like the 320x240 resolution either.

Option 1: Install DosBox on your PC and configure the mapper file:

dosbox -startmapper

Put the resulting .map file on your GameShell in the /home/cpi/.dosbox folder.

Option 2: Download an existing mapper file on the GameShell:

cpi@clockworkpi:~$ wget -P ~/.dosbox/

Furthermore, look what your configuration expects:

cpi@clockworkpi:~$ grep mapperfile= ~/.dosbox/dosbox-0.74-2.conf

If there is a mismatch, rename it:

mv ~/.dosbox/ ~/.dosbox/
1 Like

well i did it but what i don`t know is how can i configure the keys

I assume you are using RetroArch by the looks of your screenshot.
Personally, I never used RetroArch to play DosBox.

I configured the keys on my PC:

And copied the mapper file to my GameShell.

For a DOS game, I always made a menu link. Something similar to this:

echo 'dosbox ~/games/Duke1/DN1.EXE -exit -exit' > /home/cpi/apps/Menu/Duke1/
1 Like