clockworkpi

Retroarch: Not working after attempting to make it so I can change the key binds

Hey guys, so I’m new to this community. I set my buttons to be SNES instead of Xbox and so I wanted to change the keybindings in RetroArch to reflect that. However, out of the box it wouldn’t let me change my keybindings. I would try but when I pressed the new button I wanted to assign, nothing would happen. I did some searching and found this tutorial

Now I can’t run the games, at least on mGBA. If I go through RetroArch, it just takes me to the main clockwork menu when I hit run. If I go through Retro Games>mGBA, then it loads the game and the freezes when I press a button. Any thoughts on what I can do to fix this? Do I just need to do a factory reset and try again? any other thoughts?

Try updating it or pressing the reset button on the motherboard.

So I just checked for updates on clockwork pi. It said I had one and it installed, but now I can’t launch RetroArch at all. it just takes me back to the clockworkpi menu. It says I’m using 1.24. Thoughts?

Try running this automatic script to set it up https://github.com/hpcodecraft/gameshell-setup/tree/master/retroarch

1 Like

thanks for the response, like I said, I’m new to this stuff. Do i use ssh with that url or how exactly do I run the script on the gameshell?

Ssh the “setup_retroarch.sh” file into /home/cpi/ and run it from the launcher. That’s my assumption I have not tried lol

How do I ssh the file there? I’m very new to this still…sorry.

Did you try logging into it from your computer through ssh?

Download WINSCP (on Windows. I dunno for Mac)

On your GameShell, open TINY CLOUD and note the IP address.

Then type that up address into WINSCP with the password “cpi”

You are now SSH’d into your GameShell for wireless file transfer

So, I did that, but am not sure where to go to run the script… Nothing new is showing up in the launcher. or is it something in the retroarch menu?

That script just recompiles retroarch and copies the config file

But how do I run the script? I got it on the Gameshell, but I’m not sure how to run it

chmod +x setup_retroarch.sh
./setup_retroarch.sh

I ran the script with those lines and then I went to launch a game and nothing happens. It gives the Now Loading screen and then goes to the launcher menu.

You can also get the stock retroarch config https://github.com/clockworkpi/GameShellDocs/blob/748c84be546cb789b9d89e84788632db7761f766/retroarch.cfg