How to get gPSP to run?


#21

I just tried it… still just crashes. I wonder wth is going on here. I was happily playing last night. :\


#22

I notice that the original post show it run on retroarch 1.73. did the gpsp only can run on that version smoothly?


#23

No, it did work on 1.7.5. I was using it last week… I was doing some editing and messed it up and forgot to back it up.


#24

I did have 1.7.5 version, but no luck on that one before.


#25

I’m gonna try tweaking the source code eventually


#26

https://files.andressm.org/d/55bbc4544e774598a139/

Download the gPSP.so file from here.

Drag it into /home/cpi/apps/emulators/ AND /home/cpi/.config/retroarch/cores

Enjoy full speed GBA. Big shoutout to @fr500


#27

Great work Micro007. what has been changed? comparing with the previous one?


#28

I’m not sure. When the GS first released to backers, a version was tweaked by a member. The file just got lost. I have gone on the journey to locate it so everyone can enjoy it!


#29

I also have a tweaked mGBA but if you have gPSPfor GBA, then the current mGBA works fine as a GBC emu.


#30

thx u very much. Great work. i would have though you did the tweak. :): +1:


#31

I gotta give credit where credit is due. I tried my butt off to tweak it myself… but I couldn’t do it.

@fr500 is the real hero. I’m just the messenger.


#32

I try to use gpsp.so but I failed. And this is what I did:

  • download gpsp_libretro.so, and copy it into /home/cpi/apps/emulators/ AND /home/cpi/.config/retroarch/cores.
  • create a new menu with create folder GBA under ~/launcher/Menu/GameShell/20_Retro\ Games/
  • create action.config
ROM=/home/cpi/games/MGBA
ROM_SO=/home/cpi/apps/emulators/gpsp_libretro.so
EXT=gb,gbc,gba,gbx
LAUNCHER=retroarch -L
TITLE=GBA Roms
SO_URL=https://raw.githubusercontent.com/cuu/emulators/master/mgba_libretro.so.zip

but no luck, run failed

do you have any suggestions?

thank you!


#33

You need the BIOS file (gba_bios.bin)

Google it, and place it on the system directory

(In a retroarch, go to settings, then at the bottom, Directories. Set a BIOS folder and put it in there)


#34

great!
it works!
thank you!


#35

hello, can you run golden sun 2 with gpsp? It is always restart in my gameshell.


#36

Works for me man. Do you have the BIOS file in the right place?


#37

The game intro i can run same, but into the game, it will restart and repeated