How to install PICO-8 on GameShell

pico-8

#24

Oh! your PICO-8.sh should only have the first line (I accidentally had a typo, sorry about that :fearful:)

SDL_VIDEODRIVER=x11 DISPLAY=:0 python /home/cpi/pico-8/pico-8-volume.py

(assuming you downloaded the py script to that location)
I am sorry again for that typo.

If you look at the script, line 107 https://gist.github.com/follower46/69cdc41d9dc09cf9fe97b48ec4036158#file-pico-8-volume-py-L107

It launches PICO-8 for you.


#25

Comes to show how little I use the launcher these days. Shame on me.
I really hope that the GS keypad can be eventually developed into a qwerty Keyboard to be used with PICO-8 (since it is connected as a USB HID and the arduino code is available). My dear PocketCHIP is not doing so great these days.


#26

image

But it would be very slow to type


#27

Cool, but I was meaning a physical one, by creating a new keypad board and case cover.


#28

Ah thats even easier! With the arduino is very easy and its not necesarily needed to create a new board, but for optimizing space it could be better a new one.


#29

Hmm, actually, that’s what I tried first, having commented the original line out. Pico8 just exited before loading (black screen, then back to the launcher). Let me try again…

Ah yes, it was the X1? typo. Thanks so much, works perfectly! :slight_smile:


#30

Followed the instruction last night and it all worked like a charm, except for changing the launcher icon. Thanks!


#31

Been enjoying Pico-8 a lot. Alone it’s reason enough to get a Gameshell :smiley: (are there other simple ways, other than a browser, to play them games?).

Anyway, I’ve found some itch.io titles I’d like to be able to play on my GS, but since the Search function doesn’t work (what with it needing a keyboard and everything), how would I go about doing it?

Thanks!


#32

Any Pico-8 cartridge (game file) posted to the BBS (forum) can be downloaded as a .p8.png file, which you can copy to your GS (like a ROM for an emulator). Find the forum thread with the cart in it, click “Cart” to view the .p8.png file (it’s an image that looks like a game cartridge), then download it. Transfer it to the GS and put it in the ~/.lexaloffle/pico-8/carts/ directory. You should be able to access them from Splore.

Pico-8 games published to itch.io are not as easily extracted unless the author also makes the .p8.png file available as a download.


#33

Ok, figured out. There’s a typo in the intructions above. It should be:

mv PICO-8.png ~/apps/launcher/skin/default/Menu/GameShell/


#34

Thanks, @dddaaannn ! I hadn’t realized all that… Woo-hoo!

If only there was a way to sync favs from the BBS to the GS…


#35

@CocoaGeek Thanks! Fixed the typo in the post. (It’s correct in the wiki.)

@Gryzor Yeah, I get the impression that zep intended to make Splore an optionally-authenticated service that would sync with BBS stuff like faves, but it hasn’t been implemented yet.


#36

Hi all,
Thanks for the tutorial. I have followed the guide to the letter and got the smaller screen when first running the application. I killed it then through ssh, and proceeded to finish the installation. The issue I have is once I run PICO8 I get always a hard lock up in the menus. I then have to hardreset the gameshell or kill PICO8 through ssh. Any suggestions why is this and how to solve? Also If I am quick enough I can run any game and the game works without issues. The freeze is related to the menus. Halp! :slight_smile:


#37

Same happens here, i just installed the latest version and it always freezes


#38

Maybe a bug, that come with the latest launcher update?

Try to roll it back, would be interesting to see if it keeps freezing: MAME PSX lag 1.22


#39

That might have helped, just did it and now it looks stable for the last 10 minutes.
Also noticed some lag in Genesis games after appling the update


#40

Sounds great. Have had the same bugs – glad to have helped here! :slight_smile:


#41

have the same issue since updating the launcher :frowning:


#42

try to downgrade as suggested by @nouty, still works for me


#43

Yes I did that and it works better, except some of the pico-8 games are crashing. Could have been the case before, I didn’t try that many games.