How to reset the key?

retroarch

#1

Hello,
I’ve install RetroArch and I modified the keymap. But now the native emulators don’t respond well : for exemple, I can’t play Mario Kart Advance because the keys were modified.
How can I reset it ? Thanks.


#2

MGBA, MAME, NESTOPIA are just a shortcuts for corresponding RetroArch cores. So if you reconfigure RetroArch, these “emulators” will be affected too. Even the CaveStory is just a Nxengine core for RetroArch.


#3

Thank you.
Is it possible to install a keymap working for all emulators ?
Or maybe to reset the keymap ?


#4

There is no “default keymap” for the GameShell in RetroArch - there is nothing to reset to. But maybe you could restore an entire RetroArch config from the backup copy. Take a look here: Proper retroarch.cfg file needed


#5

In Retro Arch, go to settings => input =>

change “bind timeout” to 5

then select “Input User 1 Key Binds”

in that menu, select “user 1 bind all”

it will then ask you to input a key in turn, allowing you to re-bind all the keys to your liking.