I need help fixing my gameshell and if not then reformatting it

I was trying to upgrade my Gameshell from OS v0.4 to OS v0.5 to do this i followed the pinned post in this thread GameShell OS image files (v0.5)
I used ssh to get into the gameshell and I used wget to download the 0.4 to 0.5 patch.
Then i typed sudo apt-get update && sudo apt upgrade
Into ssh. This took a while…Then I used chmod to make the patch from step 1 executable. Then I ran the patch.

At first everything was fine. In the about me it still said OS 0.4 but the linux kernel had upgraded. I had read from others that the dark theme is broken with is update so I changed the theme to default before starting. I changed the graphics driver to the Lima driver because I heard that it was better now with this update
Then i rebooted and now I can’t get the Gameshell to work. I get stuck at the Happy Hacking message on startup. It just says Happy Hacking and then You have mail.

I’m wondering if this thing is still salvageable because this was a few hours ago and I can’t ssh into it anymore. Probably because the modem has given it a different IP address. I don’t know if I can use usb to connect to it because I’m not if it was enabled and I can’t enablr it because I’m stuck at the Happy Hacking sign on start up.

Any help would be much appreciated. I really like this system and had been happily playing Pokemon Crystal Clear on it. I just did this upgrade in the hopes I could eventually get the mupen64 emulator working for some n64 games also because the notes on the upgrade said this update would improve heat and battery life.

if you are on linux you may use nmap to scan all your local network to find device ip

usb ethernet may be enabled by default

else reformat, use @javelinface custom os based on 0.5 or my arch linux port

1 Like

Thank you for the quick reply. I used nmap but none of the connections it returned were the gameshell. I guess that means its internet is off. How do I ssh into something with a usb connection? I’ve never done that so I don’t know what I put into the ip field. ssh cpi@???

from [USB-ETH] How to transfer files if you have unstable wifi it seem to be on don’t know if official release take the same ip, it may be on the same netmask

on arch i fixed it to

Thank you for the reply. I’ve connected the gameshell to my laptop via usb and using ssh on either of those addresses and both return nothing. I guess I have no choice no but to take the gameshell apart and reformat the sd card.

you could also fix system using the sd card, but it must be better to reformat, be sure to dump your savestate before if you can access the sd card filesystem ^^

I have an sd card reader… What sort of image should I use for the new sd card? I’ve seen some modded stuff and I want to be more cautious in the future. Also since I’m having to remove the sd card anyways, should I just use a 128gb sd card since I have one? Or are there complications with doing that?

128GB card must work but have you such data to fill it ?

@javelinface custom image is based on 0.5 with some things fixed/updated and new emulators & game

arch linux port take an other philosophy, pretty minimal with dedicated launcher based on file explorer and system packages based for future upgrades, but may require a bit of linux knowledge

for the twice you just need the os image and use dd or any program to flash it on the card

I think I might just stick with the 16gb card it came with. I can’t get the 128gb card right now…

I just download the image I want and use something etcher to write the image I downloaded to the sd card erase the old contents. Pop it back in the gameshell and it should work again right?


in case of trouble try push the reset buttons on the motherboard

Ok thank you for the help. I finished flashing the sd card with etcher and put it back and the new OS seems to be working. I’m activating wifi now, so I can put some of my old games back on there again. Hopefully now N64 games will work too.

I want to confirm before I mess with it at all. On this new OS, the one @javelinface made, is it safe to switch to the Lima driver? Or will I break something by doing that?

yes use lima, not know if fbturbo still work

1 Like

Thanks for the help. Ocarina of Time and Banjo Kazooie are working. Do you know if PS1 games would work?

never try but yes it must work fine :slight_smile:

Yes they will! Just be aware of the conventions for using .cue files, and generating them. You don’t “Need” to, however given the way that sometimes data is stored on different “tracks” of the CD, you may run into some problems of missing music, FMV, or even huge chunks of actual content.
Here’s one that you can use to generate cues: