clockworkpi

Is there a GBA simulator with acceleration in gameshell?

Is there a GBA simulator with acceleration in gameshell?

Hi, Veronica here. The Built-in emulator is with acceleration.

Welcome to the forums! :)))

Re: acceleration, do you mean one that runs faster? Or potentially one that uses The GL drivers? Try giving the Lima Drivers a go, going into settings, and choosing it in the graphics driver setting.

For a faster accelerated emulator, give the standalone emulator a go. The emulators with a “+” sign are the standalones, according to what people in the forums refer to them as.
What this basically means is, they don’t rely on retroarch.

You will also need to source yourself a Gba bios file in order to get it working, and put it in the correct directory.
@Rebusmind made a great post covering this. In fact have a look at the custom image in general, if you want an accelerated experience with multiple standalone emulators.

Custom GameShell image (v0.3) with standalone emulators

Thanks for your reply. What I really mean is whether it can run fast-forward, as shown below (this is a screenshot I installed on Android), or not?

From within retroarch, there is a toggle for for this.
I haven’t tested this, but I’m guessing it should just be a frame skip toggle. Your mileage may vary, depending on what game you’re frameskipping, and which core you’re using.

image

What simulator do you use? I use the MGBA simulator in the system, but I cant find the interface in your screenshot.

I’m actually using the GPSP emulator via retroarch, but it should work with MGBA too.
It’s something that you set via retroarch to be applied across whatever cores you use. It’s a great way to unify controls.

Settings->input->hotkey bind

In your screenshot, you are in the quick menu. Go back until you are in the root menu. On a side note, the quick menu can be extremely customised. I have made mine minimalistic with just state save options and core options.

You will need to SSH into your Gameshell to manually modify your retroarch config file, since the input timeout is expecting a game pad button, when the Gameshell arduino is recognised as a keyboard. There are quite a few threads covering this. I personally like to use nano.

That worked. Thank you.:smile:

1 Like

Wonderful! Glad to help! Don’t forget to tag the thread as solved :slightly_smiling_face:
Have fun!