Just turned on my gameshell and stays stuck on “Welcome to clockworkpi” screen

What should I do? Do I take it apart?

What changes did you do last time? Reverting the changes might help

Otherwise reflashing would work too, and not OS 0.4 is released.

1 Like

Check if your SD card is not full !

1 Like

that screen staying there means your kernel has most likely crashed. if its not an SD card issue and a reflash isnt fixing it hit me up i’ll walk you through disabling the “splash screen” so you can see and post what happens from the kernel boot

1 Like

The only changes I did were just changing the icons, but my gameshell would work normally after that

How do I check if the Sd card is full?

You should be able to access on SSH or with WinSCP (SFTP).

You can use the command df

Also if you added new icons I suggest you to remove them just in case. Verify you didn’t mess up with the name of the files (icons and menu entry). The launcher is very sensible with that.

1 Like

Had the same problem after moving around some files to tidy the system up. As I hadn’t done a lot with the system yet I put a fresh 0.3 image on the SD card and after that it ran much better than before. Now I’m a bit more careful with stuff like that. ^^

Thats very common case, when changing launcher scripts or files, if there is a setting that the launcher doesnt like it wont boot.

For example, it happened to me that changing an icon file got it stuck on loading because the owner of the icon was root instead of cpi

this is 1 of the biggest reasons I’ve wanted someone to rebuild the launcher with a robust error checking/fallback system. anyone with python skills wanna take it on?

If I were to flash the memory card, will it erase everything?

Yes, but you can backup it and copy it on the newly flashed system

How do I back it up then? I’ve worked hard getting all my games and icons for this little system, I should’ve just bought a retro boy…

While I like the look/design of the current launcher, I really wish they’d start using an alternative launcher. This one is so fragile and the performance is poor when there are lots of ROMs in place for a system. It makes for a poor experience as a user, and starting over from scratch with every OS update makes the problem worse since we’re given more reason and opportunity to break the fragile launcher by having a file in the wrong place, etc. It also doesn’t help that they switched the location of launcher files in the past, and there are still threads on the forum with old info. Their documentation, product support, and development/release plan are all pretty lacking, it seems. I’m sure it’s a nightmare for new users, since no one should be expected to read every forum thread going back 6 months or more just to follow all the changes and tweaks required to get basic functionality working. Even having been around for a while, it’s still a pain.

On the plus side, the system hardware is excellent, and I’m hoping some of the user driven efforts will help. I just hope the official releases don’t continue to confuse and drive people away. I really like this device and want it to be around for a while with an active community, but they aren’t exactly doing things to encourage that. :frowning:

I haven’t tried that launcher replacement someone posted which was ported from another system (dingoo/gp2x stuff I think?), but I’d expect it performs better since it was native code and not just python. While it’s nice to have the Retroarch cores directly loading from the launcher, things seem a lot more stable and easier to maintain running separate stand alone emulators since having any ties to the current launcher makes everything more fragile. Building everything around the most fragile component seems a bit… risky.


I fixed it by deleting a game for psx, no need to delete everything lol

As part of the community driven effort, maybe we design a bare-bones (but still decent looking) launcher system. No need for bells and whistles until the core functionality is solidly designed and working.

I could “try” to take this on, but between my full time job and freelance work, I have very little time to commit to larger efforts. Small to medium sized tasks I should be good for though.


Check if your SD card is not full !

facing the same issue , checked the sd card too… it’s not full…

1 Like

What was the last thing you did

looks like your SD card in running out of storage, clear some memory on your card and try again !!

@smithclarkson try my solution out and let me know if the problem is still present.