Keypad replacement needed

Sure thing. I bought it from Amazon about a week a go and haven’t had the opportunity to piece it together until now. Everything is put together correctly, cables are where they should be screen powers on, except it doesn’t recognize any input. I switched the cables around and nothing happened. I even used the cable for the speaker to see if it was perhaps just the cable and even then it still didn’t register any input. I tried flashing the msd to v0.4 to see if maybe it was bug in the programming like some of the forums said and still nothing happens. I don’t know what else to do. I should also note that the time on the upper right hand corner continuously reads 4:07 sometimes jumping to 4:08 but when I turn it off and turn it back on it goes back to 4:07.

Welcome to the forums!! I hope someone can help you before you need to wait for a replacement. The satisfaction of troubleshooting is part of the fun. (Well, for some ;))

I mentioned this in another post, but check your pins. They are super tiny, and flexible. Sometimes two pins end up in one slot.

Try installing it all removed from the plastic housings. They don’t do it any favours re: cable alignment.

Re: the time and battery gauge, it only refreshes when it detects an input change. Since the keyboard isnt detected, that seems to line up.
As to why it’s always 4:07 on reboot. Hmm. Perhaps since it’s never experienced a reboot, this was the time it is by default. Very interesting!

The keypad board is arduino based you could reflash it and see on the pc if it gives an output

I made a fork of the keypad code that has a flag to set up for debugging and it shows you the keypresses GitHub - Mihaylov93/Keypad: GameShell's Keypad arduino code.

I checked the pins, they’re all straight, and I have done it while out of the case, I spent the last hour doing it without the casing. All I had were the screen, the battery pack, the keypad, and the mainboard. The screen comes on, I even de ided to plug in the light keys and see if they had any input. Nothing happened but they do light up, which leads me to believe that there is power running through it.

I’ll try to reflash the keypad in the morning when I get back from work. However do you happen to have a dummies guide on how to do it. My current technical knowledge goes as far as ctr+alt+del. (Okay maybe a little more)

Tada! Dummie guide!

A complete random thought! The cable could be inverted! Doubtful but worth a try.

I read up on the inverted cables and tried it too, no luck. I even used the cable for the speakers and inverted those too and still nothing. I’ll check that link out and try it once I get home, I’ll let you know if it worked or not.

1 Like

Is there any chance this is an issue with a batch of them? I purchased the same thing through Amazon (red case if it matters), and I have the same issue. The system boots fine, but the keyboard is not responsive to any input. I’e re-assembled it all twice, checked and reserved the cable, made sure it’s aligned correctly in the plug… I was registering here just to start asking the same question…

I think it might be since I’ve also read on other forums that a few people had this issue. I’ve tried reflashing the keyboard like the post up top said and I keep getting failures. I think I’m going to have to get a replacement. Board for it

Hi, would you please send an email to help@clockworpi.com? So we can offer further help like place a replacement for you.

I already sent one. Thanks for the reply

1 Like

Got it. My collegue will follow your case. I’ll also keep an eye on it.

Meantime, while waiting for a reply, have a look at this thread.

One user mentions pushing a reset button on the back of the main board.

Another mentions low power being the problem, and to leave it powered for a few minutes.

Simply removing the rear casing seemed to help another, but this all seemed very hit and miss.

Either way, it sounds like you indeed do have a dud board, seeing as most people’s work perfectly 100% of the time. If you can get your current one working meantime: BONUS!

Yeah and the best thing to debug it is connecting the keypad to the pc if the pc doesn’t detect the arduino board then its faulty, but if it does then you know you could do something about it!

1 Like

I had my gameshell on for a few minutes while I tinkered with it and it still did not work for me. I hit the reset a few times as well I even powered it off completely and powered it back on. I also took it out of the case, and left it on for a while and still nothing.

1 Like

I am so so sorry for the inconvenience. After sales service is on the way. Would you please to tell me your order number so I can accelerate the progress of your case?

I ordered mine off of Amazon, you want the order number from that?

I emailed you my Amazon order number, did you receive it?

Hi GameShellers,
GameShells and D.E.O.T.s that were sold in China during 21st August to 26th August, 2019, may have a problem of Keypad not responding. We’ve found out that was because the packing team accidently packed some empty (no program burnt in) educational Keypad in to regular packs. We are really sorry for that.
We’ve been working with our sales partners to fix it. Most of GameShellers that are involved in this situation have already received the replacement.
If you are involved and have not received the replacement Keypad or tracking info, please contact your dealer, we’ll fix it ASAP.

各位Game Shell的玩家们,
2019年8月21日到8月26日在中国地区线上销售平台购买的GameShell和DEOT,键盘板存在芯片未烧录导致键盘板无法使用。原因是工厂将投放教育机构的未烧录键盘板包装到了常规版大货中,对此我们表示非常抱歉。
我们官方已和各个销售渠道在积极处理本次事件,常规版做过烧录的键盘板也已经都递送给本批次用户。
如果您还没有收到售后的键盘板或者物流信息,请随时与你购买的平台联系,我们会第一时间处理。

3 Likes

Oh so that means there is no bootloader so they can’t even reflash it without another arduino and/or other equipment. We could create a guide for those who want to thinker and are able to burn a bootloader meanwhile they wait for replacement.

2 Likes