New device but keypad doesn’t work

Hey y’all,

My device isn’t working…the keypad. I even reflashed with version .3.
can anyone give me some advice before I settle on it being the hardware :frowning: ? I waiting months for this and to have finally receive it yesterday and this being the outcome is quite disappointing.

Email to , If possible please provide some photos, especially the keypad.

Thanks, video and photos sent

Mine did this twice today too. I opened it and plugged in power and rebooted it. For some odd, unscientific reason, it worked and the keypad works again. My guess is that there is a latent FW bug. It happened a 2nd time and I did the same thing… at first it did not work but then I rebooted and it was back. Good luck.

Just did it again. This time I had to unplug the keyboard… replug and reboot, it came back

Thanks Peter, is there a way to do a hard reboot or reset? I just press the button until it turns off and then press it again. Are you disconnect the keypad from the motherboard or from the keypad module itself?

Jay, it happened again… I think it is a bug booting with low battery. Try plugging in for 3 minutes and trying it again. Let us know if this works, it will help isolate the bug and make it reproducible.

There is a reset button hidden on the opposite side of the logicboard from the power button. I press it with an ink pen when needed.

Hey Peter , still no luck after the charge. :frowning:

Take a close look at the pins. I accidentally bent one on the connector to the lightkey, rendering it useless. I found that one of the pins was pushed out, against the inside of the plastic housing of the connector. I bent it back with a straight pin or needle, connected it back up and it worked.

You guys rule!! It was bent and I didn’t even notice it. Struggle straightening it out, crack the keypad connector port case a little in the process…but it’s working

1 Like

Interesting… after reading this. I opened my box to see where the problem had gone. I simply changed the back case, and the problem was back!!! I struggled with it for many more hours. Finally, I found something that seems to work all the time. I disconnected the battery. I tried powering on (without the batter) and for good measure, I hit the reset switch @lasvegas pointed out and it came right back! I am glad that yours was a pin issue, but mine is/was not. I still think that it is a latent FW issue.