clockworkpi

Lets play Tyrian

OpenTyrian ready to take off on your GameShells!

IMG_5539 IMG_5540 IMG_5542

Get it at: https://github.com/pleft/OpenTyrian/releases/tag/2.1.gameshell

Instructions

  • ssh to GameShell
  • From home/cpi:
    wget https://github.com/pleft/OpenTyrian/releases/download/2.1.gameshell/OpenTyrian.tar.gz
    tar -xvf OpenTyrian.tar.gz
    wget https://github.com/pleft/OpenTyrian/releases/download/2.1.gameshell/OpenTyrian.sh -P /home/cpi/apps/launcher/Menu/GameShell
    
  • download icon and save it to launcher skins
    wget https://github.com/pleft/OpenTyrian/releases/download/2.1.gameshell/OpenTyrian.png -P /home/cpi/apps/launcher/skin/default/Menu/GameShell/
    
  • Reboot GameShell and select the OpenTyrian icon to launch the game.

Some great icons @Nielsvd and @lasvegas provided:

https://aws1.discourse-cdn.com/standard17/uploads/clockworkpi/original/2X/8/875c0a9a1d4194186783f7009518e034e265ad45.png

https://aws1.discourse-cdn.com/standard17/uploads/clockworkpi/original/2X/0/01dfdf64a189aed9a6513a5863916e5fb28272a3.png

https://aws1.discourse-cdn.com/standard17/uploads/clockworkpi/original/2X/1/11d3ab8e20886d522d241d05920ebab82b869678.jpeg

5 Likes

It doesn’t launch and doesn’t have an icon. Is there support code (ROM) that needs to be installed?

Did you follow the instructions? In the tar.gz file there is both the executable and the game data. No need to download anything more. Can you check if the executable opentyrian file is executable? (chmod +x opentyrian). For a decent icon we will have to wait for @Nielsvd if he is kind enough to provide one. Also check if you changed the paths for some reason e.g. unzipped the tar in other directory than /home/cpi

Oh and it requires SDL to be installed (not SDL2 but SDL)
sudo apt-get install libsdl1.2-dev

It worked fine for me, did you download it to the correct directory?

Personally I think it makes more sense to base it in the games folder, but that’s something I can easily tweak myself.

I also didn’t need to manually install SDL, just following elefas’ instructions worked fine.

Nice so the package is ok, thanks for verifying it. Happy shooting! :slight_smile:

1 Like

Ohhh god what a flashback! Worked perfectly first time :slight_smile:

Thanks so much man!

1 Like

Here’s two little icons, maybe there’s one of your choice :slight_smile:


1 Like

Thanks @Nielsvd !!! Once more great work! I like both but I’ll go with the second one, the “tyrian” logo although nice is hard for my eyes to read on the small GameShell screen. I will update the instructions to include downloading the icon.

Turns out is was a bad download of OpenTyrian.tar.gz. Deleting the original and re-downloading it fixed the problem. I also created an icon before seeing that @Nielsvd did. Here’s mine!

Thanks!

OpenTyrian

2 Likes