MAME PSX lag 1.22

My MAME and PSCX games are lagging now like they never have before. This is after the launcher update 1.22

Anyone else experiencing this?

Same problem here. I’ll try tout restore old version.

No problem here, same version 1.22. Both MAME and PSX work perfect

Me too on all Emulators (RetroArch, PSX, etc.) even FreeDoom and Pico 8 are lagging like hell or getting uncontrollable after a few seconds.

I have even resetup my GameShell (thought it was my fault) – after I update it to 1.22 it got stuck again. :confused:

@yong @hal any suggestions?

I just checked with my morning coffee. MAME is still incredibly choppy. I’m running Tony Hawk 2 on PCSX and it seems to be choppy as well. I thought I isolated it down to a usage issue but it’s not…

Full battery, fresh boot. Still lagging on 1.22.

try another update?

and next time ,wait the releases page out to update

in middle of development time, there maybe an unstable update avaiable ,because We use update to test new functions ,too

1 Like

How do I go about downgrading to 1.21?

I am pretty sure current version works well

you can try another update

if you really want to downgrade
just ssh into GS
cd ~/apps/launcher

git pull && git reset --hard 4ad8806 && sudo reboot

4ad8806 is the hash of 1.21

you can see this on release page of github

Sorry for the inconvenience


Hey no inconvenience at all that’s the beauty of its hack ability!!


1.22 is released

here is some screenshots about the new GSNotify

also if you are interested
you can checkout the readme for more detail










The same problem.
After update to 1.22, when running retroarch, GSNotify will take lot of usage of cpu, then retroarch lag.
When GSNotify displayed information on screen, then retorarch will pause and cannnot use.

try update again

maybe you got a bug version

I have tried " git pull & git reset --hard 4ad8806 && sudo reboot" and update again, still lag…

git pull & git resret --hard 37e4d65

I tried…
Did your retroarch programme has four llvm-pipe* threads which have a lot usage of cpu?
I found that gsnotify also use llvmpipe.

you can check out the code of gsnotify
it will sleep every DELAY_FREQ,default is 30secs
so it is impossible to use a lot of cpu

I tried going forth and back, even though I am sure git will make sure by comparing checksums that you don’t get a buggy file.
No changes, lag on emulators and freezes of PICO-8 with 1.22, no problems with 1.21

can you do a md5sum in 1.22?

cpi@clockworkpi:~$ md5sum apps/launcher/

mine is

8942b2ba5f7601aa49737249da43a6da apps/launcher/

just want to know what’s the problem

cpi@clockworkpi:~$ md5sum apps/launcher/
8942b2ba5f7601aa49737249da43a6da apps/launcher/

Hm. Mine is too. What I noticed: Weired square black rectangle flashing in the middle of the screen. Haven’t had that before the update.

that’s normal

because twm has no ALWAYS ON TOP feature, so I had to create gsnotify first then hide it

if the gsnotify-arm is right, that should be no lagging problem

I am so confused, I ran the gsnotify all day , all works well