Manjaro fails to find my SSID

Hi everyone, picked up my DevTerm after a long time, found out that the original ClockworkPi version of Arabian does not update anymore (since its hirsute), and decided to try out Manjaro. Flashed the 20200725 image and it booted without any problem. Fixed the screen rotation with with this tip.

First a big thank you to everyone who worked on this!

I have yet to make wifi work, which is strange because I thought this was a solved problem. The device does show up with ip address and I can use nmtui to add a connection. However, two strange things persist:

  1. I can add a connection, but the activate screen of nmtui is empty.
  2. When I reboot the machine, Sway tells me that the machine is connected to my home wifi. However, the moment I try to actually connect to anything (packman, firefox, etc), it fails and the SSID at the menu bar changes to wlan0.
  3. nmcli device wifi connect [SSID] password [PASSWORD] fails with an error saying that it cannot find the SSID (but I am connected to that network as I am typing this on my MacBook).
1 Like

Before I lose the connection, I can see the SSID if I do nmcli d wifi list. However, once I try to do anything with it and lose the connection, I can never see my SSID again in that list. This is very strange…

1 Like

have you updated the system? pacman -Syu and reboot afterwards.
I remember at least one recent kernel had wifi issues…

1 Like

Trouble is, without wifi, I cannot run system updates… :frowning: I did realise that the latest image is July 2022 but kneels have been continuously released after that, and also Manjaro ARM now supports DevTerm A06. However, no image release there, I have to build the image using the installer.

I think I will either try the installer, or find a USB Ethernet. Will report back.

Happy to report that the system update fixed everything - a $8 USB Ethernet cable to the rescue. Running 6.2.7 kernel for DevTerm now. Thanks!!

Looks like my claim to victory was premature… the wifi still refuses to work at home. I think it is okay at my work, and I suspect it is the Orbi routers that I use at home, and the fact that it uses the same SSID for 2.4GHz and 5GHz. Anyway, I think I will try the mainline Armbian now. It’s a shame, because I was growing a bit fond of Manjaro…