Mupen64 - N64 Emulator running

if your deb file is ready for a release i could host him on gameshell alternative repo :sunflower:

i also writed a tiny guide about packaging

That video is awesome, the game is running almost perfectly.

I can’t wait to play StarFox 64 on my GameShell <3

I have some trouble finding the correct values for the Lightkeys to assign C-Left and C-Right.
KeyValues for Lightkey 1 and 5 work perfectly fine. I can’t access the others though.

Any advice?

How would I need to adapt this to play Super Mario 64?

You should try some different settings in the mupen config file to determine the settings to run the rom flawless. :slight_smile:

Edit: Btw welcome!

Thank you, I’ll start messing with it now!

can you please share me the compilation parameters of the *.so ?

All steps done / executed scripts are written down in this thread already. :slight_smile:

I got it,thanks~
I don’t know why your *.so work perfectly, and my complied *.so very laggy.

You can have a look at these .deb files I created from my installation:

I am trying to run Mupen64 since it came installed on 0.4 but for some reason the roms are not loading i just get the loading screen then a black one and it goes back to the menu.

Thanks for the thread OP…
I got this working using the instructions you had in the OP… (using Clockwork image 0.3)

for people that only had audio like @doodom and @lasvegas – I think that if the screen is black (in sleep mode) when you run the command via ssh, then it won’t ‘wake up’. Maybe that’s the cause?

Banjo doesn’t seem to run very well though, even with the cfg you provided… Is it possible there’s some other configuration that we should be looking at?

Hello there,

I agree with the Sleep-Theory.

Everything I tried to get it running is written down right here.

That makes sense. I’m just thinking that there could be something different about your configuration prior to running those things.

Like have you maybe stopped any background processes or removed/replaced any system resources with some alternative?

EDIT: I also wanted to remind people to try using the “Performance” power setting for the best results.

Nope, nothing i can think of.

My OS (0.3) is just right out of the box without mayor customization besides the steps I described.

Would it be possible to create the core of mupen64Plus to use it with retroarch?

figured I would share this here.
if you have 0.4 and mupen is NOT working (which it doesnt out of the box)
what you have to do is use putty and edit /home/cpi/apps/Menu/20_Retro Games/80_mupen64+/action.config

and add –plugindir /usr/local/lib/mupen64plus/

see below for “instruction”

cd /home/cpi/apps/Menu/20_Retro Games/80_mupen64+/
nano action.config

**ALTER** the line ROM_SO=/home/cpi/apps/emulators/mupen64plus --gfx mupen64plus-video-rice --fullscreen
**TO READ** ROM_SO=/home/cpi/apps/emulators/mupen64plus --plugindir /usr/local/lib/mupen64plus/ --gfx mupen64plus-video-rice --fullscreen

I personally also modified the EXT= line to read EXT=n64,zip,z64 from EXT=z64 because I have some non compressed roms.

1 Like

Thanks for that! I can confirm that this does indeed work; albeit running extremely slowly using the either the FBTurbo or Lima driver.

I would suggest changing power profile to performance it does improve it with the hardware driver

Thank you for the steps, how would I do this on Filezilla? Or it’s not possible?

EDIT: alright tried the steps but all I get is a black screen with just the sound of the game