Mupen64 - N64 Emulator running

Sounds great, the update part will just be,
“sudo apt-get update && sudo apt-get upgrade -y” ?

Also, would I be able to do step 3 from FileZilla then the rest through terminal?

But you can take credit of being awesome :+1: @javelinface

That should be good re: the update.

Step 3 onwards; Sure, you can do whatever you’re comfortable with at this stage, since you’re just running scripts. :slight_smile:

And aww shucks. It’s a community of people who are all awesome! I’ve just got the patience of a saint. :wink: (and love seeing people happy! :))

Fingers crossed! Let me know how it goes. Whoops it’s 3:30am! Work in 3 hours. Good luck!!

1 Like

Yeah I give up, the same problem is there, how can I uninstall all of it? @javelinface

Oh what the heck?? Even after doing an apt-get update/upgrade?? Did the step 4-5 take forever? You might need to let it do it’s thing and just wait it out. As for uninstalling it, the GitHub page with the emulator (and the emulator itself haha) has instructions.

Do you know how to change permissions with chmod? You’ll need to do that to the uninstallation script. Actually now I’m thinking about it, perhaps you might have needed to have changed the permission of the installation script; or at least run it as root/sudo.

How to uninstall:

1- Add execution permission to uninstall script (only the first time):

chmod +x
2- Now run the script:


This is running it from the directory you installed the GitHub emulator and followed the instructions. But then, I guess if you were following the instructions, all things considered, the emulator should be working. Let me know if the script is there.

… hmm, want to try and have another bash at it, this time actually working with me, and telling me each step that you do?

How would I do step 1 to uninstall? :sweat_smile:

Ah!! If you didn’t do this to the initial “installation” script, then this could be the reason you’re not getting video!

Ahem. Back on track. Chmod is what you use to change the mode of a file, ie permissions. +x gives it execution permission. You need to change this for the; if it even exists.

You’ll need to know the directory where is. Either run it from that directory (as implied above), or put the file path in place of

If you followed the instructions initially when installing it, you would have done the same with

If you can’t find, it’s not the end of the world. Just means you’ve got some vestigial files lying around. They’d just be taking up space for now. However, if something else ever gets released that depends on any of them, you could have some version clashes. I always believe in taking care of small problems before they become big problems.

I found everything in a neat file, alright you said to chmod which file to make the video work? @javelinface


chmod +x

If you didn’t give the execute permission as per the instructions, it may not have all the correct permissions to install the dependencies required for video!

Ahh yes!! This is why I wanted you to post every step of the way before! I figured there was a step that may have been skipped!

I’m guessing it was just too hard and troublesome? If you post all of the steps you personally type into a command line, we can help you better. :slight_smile: Anyway let me know how you go! I hope you get it working!

Also, have a read of that read me in the directory you have posted. That’s got the installation installation instructions. There could be other steps you may have missed.

Just for the clarity, the method you’re using right now is the method posted here: Mupen64 - N64 Emulator running

The previous instruction I gave were for @Hawanna’s script, since it seemed like you followed the above mentioned method without success.

1 Like

Will do, I’ll come back with results :+1:

1 Like

I don’t know how will Mupen64 will work on GameShell and if it works that will be impressive. But on another hand I download the Mupen64Plus for playing retro games on my old PC which has WindowsXP software and surprisingly it works, for now. I’m very satisfied with the perfection of the gameplay.

Best way to find out how it runs is to install it yourself :slight_smile:

Just for the sake of comparison, I have recorded footage of if running. It’s the same video that the OP posted a while back. Hopefully this shows that you don’t need go do anything special or fancy to get if running.

It was installed using all the instructions in this thread, on a freshly formatted 0.4 image, just using the DEOT variant, because I wanted to test it out.

Edit: Removed this, since I was running out of dropbox space.

N64 emulator mupen64plus running pretty SLOW on Game Shell when I am playing “The Legend of Zelda: Ocarina of Time”

If you want to play the N64 games smoothly, use the v0.3 with lima drive, a lot of games run smoothly, but maybe some picture err.
“Zelda: Ocarina of Time” can play with 45-50fps.

I haven’t tried OoT myself. Perhaps upload a video of it running and your config file. I find that different games require different settings.

set the value “ScreenUpdateSetting=4” in .config/mupen64plus/mupen64plus.cfg, then many games can play :slight_smile:

1 Like

Is it possible to show a video of this in action?

Also I’m guessing you mean games run better, and not with a higher compatibility rate. There will still be a few black screen games.

A list of the games that you have running well with this setting enabled would be great. In fact of I remember, I might start a new thread with a mupen compatibility list, and accompanying config file.

On a side note, 40-50fps In OoT is quite insane. Most
emulators natively on PC without tweaking run at about 20-30fps. I am seriously wanting to see your Gameshell doing more! My Banjo Kazooie was running at about 30fps.

Here’s my config for anyone wanting to try, using the above recommendations. It’s my internal config file, so it’s got a lot of undocumented (in this thread) tweaks to it, and I can’t honestly remember what I’ve changed. I can only manage up to 30fps, which for me is pretty much on par with what I’d expect from the GameSH.
Also I modified the action file, as the video plugin didn’t have the .so extension.

Here’s a video of my OoT and Starfox 64 running at about 20-30fps. Sorry, I turned the onscreen counter off, but you can tell visually.
Pardon my terrible playing. I was trying to balance my phone between my wrists!!! And ahem. Controls need a bit of adjusting it would seem.

All this worked perfect for me, and the action.cfg edit you rock.

1 Like

Glad it helped! I’m still tweaking it when I have spare time, in a desperate plea to get rid of any other graphical artefacts. That and trying to get a GUI to work, so it’s a more user friendly experience. For now, it’s a fun tweaker’s sandbox; which I am all for!

1 Like

I find how to save or load the game state, use this config below( /home/cpi/.config/mupen64plus/mupen64plus.cfg):

Kbd Mapping Save State = 269 (shift+select to save game)
Kbd Mapping Load State = 270 (shift+start to load game)
Kbd Mapping Fast Forward = 32 (press select to speed up the game)
Kbd Mapping Stop = 8 (if you want use shift+Menu to quit the game)

1 Like

Does anyone have any success using the other video plugins other than the default one, i just get black screen, trying glide64,

Would like to get episode 1 racer to work without the half screen glitch but idk if its possible. I was surprised that 1080 Snowboarding ran so well though

EDIT: I got episode 1 racer working , you just have to disable the expansion ram in the mupen cfg. But its really slow, obviously, that game needs a fast computer to run at decent speeds/