clockworkpi

Mupen64 - N64 Emulator running

If I may, I’m trying to get OoT to run better (right now it’s very slow, lots of stuttering especially in cutscenes and dialog. Although I don’t know what I can realistically expect from the GS? Have no experience with emulation). I’m on your custom DEOT OS and just looked into the mupen config, ScreenUpdateSetting is already set to 4, so I assume you already applied your config changes to your version of the OS? Is that correct? If not, could you please elaborate on how to optimise, as the config you linked to in your dropbox is not available anymore. Thank you!

Hello, Yes indeed! The latest version is in my custom image. And strange, it should still be there! Indeed ScreenUpdateSetting is set to 4, so it should run fast. Also, OoT for me is … actually very playable. Hurm. Like, actually smooth. Have you tried different kernels, and clock speeds?

Hi,
I haven’t really tried anything yet apart from checking the ScreenUpdateSetting.
Let me show you a video of how it runs, maybe I’m expecting too much? I feel like this morning it runs much better than last night for some reason. Walking around is actually quite fine, apart from the flickering on the ground. In interiors you can can hear the slowdown / stuttering in the sound mostly. Again, I don’t really know how it should run, so I’m fully expecting your reply to be: that’s how it is :smiley:

Video:

Edit: One more thing, I’m trying to add a OOT launcher icon following this guide


But I’m having trouble figuring out where to link to the mupen64plus as it is not in the cores folder?

Ah, well! That’s what I call very playable. I think it’s just the shadows that are in Kokiri forest that are graphically stupid. Once you’re out of there, it’s all good. Eg, the first dungeon basically plays flawlessly. So yes! That’s how it is basically is my response!

As for making the icon, mupen64plus isn’t actually in the cores folder, since it’s not a core that’s used with retroarch.

Here’s what you can use though: (change the name to your rom file name obviously)

mupen64plus --resolution 320x240 --fullscreen /home/cpi/games/mupen64/zelda_oot.n64

Yes you are right, it is totally playable. For some reason I remember it being much worse last night, or maybe that was just my brain slowing it down :wink: Or, I’ve been playing too much BotW lately and my expectations are way off because I’m forgetting what I’m playing here :wink:

Anyways, thanks for letting me know and thanks for the hint regarding the launcher icon. Will try that out!

1 Like

Hi! I am brand new to Clockwork pi and loving it! I have some experience with raspberry pi’s, but had a quick question for the gameshell. Many games work wonderfully, but i know some are tricky and require tweaking how the emulator runs. Is there a similar setup for mupen64? i am trying to get Donkey Kong 64 to run, but I always hit a black screen and i get kicked back to the starting menu. I’m using this build, if it helps.

Thanks in advance!

Welcome to the forums :slight_smile:

Ah! This is to do with the 4MB expansion toggle.
If you go into the config file located in ~/.config/mupen64plus, you can edit the section under “core” to enable the 4MB expansion.

From memory I had it disables to allow Star Wars Episode 1 Racer to work. But to be honest, that ran kinda terribly anyway, and really isn’t that fun on the gameshell.

Donkey Kong 64 surprisingly does run quite well! It does stutter a bit with extended audio, eg the DK rap, and when there is extended voice acted dialogue, eg the first cut scene. The game pad mapping using my custom OS has the game pad X(SNES) as Z to crouch and A(SNES) as R to straighten the camera. Y(SNES) is B, B(SNES) is A, and shift + ABXY is mapped to the C keys.
You can state save with shift select, and state load with shift start.

I’m currently playing with my gameshell overclocked using the 5.5.9 kernel. It could work with it a stock kernel and clocks, but from what I’ve tested, it runs nicely with what I’m using.

I’ll go ahead and add that to my todo list for the image, ie putting the 4MB expansion pack support back in. Thanks for letting me know! Enjoy spending hours collecting an insane amount of collectibles!

1 Like

works like a dream! There goes what’s left of my weekend. BTW, thanks for the amazing custom image. the tutorial was easy to read and understand why things were set up in a particular way. Now to fiddle with overclocking for my next project!

1 Like

There’s a great thread that covers just that here
It’s what I’ve based the overclock in my image off of, just enabling a few extra governors. Just watch out re: a screen flicker issue that some people have had, using an alternative Kernel. I’m still waiting on a different revision board to arrive in the mail (R16-J as opposed to my two R16 boards) to see if it makes a difference.

Hey @javelinface how would one go about activating the 4MB expansion for the mupen64 plus I tried to play smash Bros and it did not load passed the opening cut sceen

Hey, smash bros. Isn’t a game that ever supported the 4MB Expansion pack so enabling it won’t actually do anything.
That would be another setting we’d need to fiddle with.
Work has picked up again so I’m getting quite busy, but if I have some free time on the weekend I’ll look into it.
I’d just be doing changes to the config files one at a time, testing it as I go, and rolling back when it breaks. Crude I know. It will be time consuming.
You’re not the first to have a problem with smash bros. In particular.

Here’s a good resource for what settings to tweak.
Note that smash bros is listed as a game that cannot be played on the raspberry pi. I would assume the same for the gameshell unfortuantely. But who knows? Give it a shot.

https://www.raspberrypi.org/forums/viewtopic.php?t=58395

Oh snap, well then nevermind on that then lol. I will poke around to see that I can mess with but I will be carful this time lol

Just keep a backup of your config. (In my custom os I have a spare mupen64plus.cfg.bak in case you mess it up)
Also, strange! I can get past the opening cut scene, and start a match, but 3 seconds in, just the video freezes.
Looking through all the comments on that link above, you can see that it’s a case of fixing one thing leads to breaking two more. At the end of the day, smash bros was more of a fun party game to play with friends. It’s not that enjoyable to play solo on the Gameshell. I wouldn’t try and spend too much time fixing it with this in mind. That’s not saying I won’t anyway :).

Yeah, your right back to OoT then and MM with starfox in the wings(pun definitely intended)

1 Like