My DevTerm R01 was dead

Hello guys, I got my DevTerm R01 on Aug. 5.

I tried some tweaks for my DT R01 referenced by some topics on the forum for some days.

And, I changed the 18650 batteries to a smaller size this morning, it looks to have worked well before testing the thermal printer. however, when the printer working started, it was power offed immediately.

Now, my DT screen does not show any information, and only the power led is lit.

Did you guys have some ideas for this problem?
I used Linux for some years, but my skills are still at end-user levels.

Thank you!

Looks like a typical overcurrent/undervoltage protection. Long press power button (10 secs) to completely shut it down, and then you can power up again.

Thanks for your reply.

Unfortunately, It still not working.

I still finding some solutions

I found one more problem.

when I tried the boot my DT, smelled of burning at external board U2 (is it a level shifter?)

I don’t know what relations between the burning smell and not bootable situation.

I’ve confirmed that sometimes it won’t boot with an 18650 battery in it. (It booted after removing the 18650 battery)
*I think maybe this is a 18650 issue rather than an R01 issue.

Thanks for your reply.

I already tried to boot after the battery removal. but it is still not bootable.

In my case, the battery board or main board was got damaged by the battery.
I used two types of 18650 batteries(all have protection circuits), the one has an LG cell, other has an unknown cell. (LG cell battery has no problems)

You can check if you can boot with USB-UART even when the screen cannot be displayed.
Try using a short USB cable, about 20 cm.
https://github.com/emutyworks/DevTerm-R01/wiki/Connect-with-USB-UART

You could also try a minimal configuration: remove EXT board, remove battery, plug in usb power then boot.

Thanks! It works on minimal configuration!:slight_smile:
Just Ext. board only dead.

Glad to hear the core is not damaged.
In the meantime…

image
Something on EXT board may be fried and shorted.

If I were to take a wild guess it would be “U5”, the motor driver, or “U2”, its power supply.