DevTerm R-01 module dead?

After received my percel(2nd June), My DevTerm R-01 is work normally with USB-C charging and 18650 battery.
Last Saturday(5th June) I changed local timezone , and reboot the system with “reboot” command.
The shutdown process looks like process normally then I expect boot up system but system is not booting up and device started a resonant sound(not make it via speaker).
I once holded on switch button and power off it completely, and power on again, but this situation not changed.

I removed all parts from device and check one by one but cannot see any physical damage on system boards.
Then I rebuild one by one and make sure that resonant sound made by R-01 chip board itself.
When I removed the R-01 board from CPI v3.14 board and turn on the power, that sound not happen.
I don’t have other board like CM03, A-04/06 so cannot validate more.

Does anyone has a simmilar issue or have the knowledge to diagnotics this ?
I sent this issue to help account but not get any response yet.


Try to reflash the microsd card to rule out the possibility of filesystem corruption.
Did you update the system?

@pkr Thank you for your response. Forgot to add it but already try to reburn the OS image into MicroSD card but no change the situation. I also tried new microSD card, but this is also no change situation.

I keep using Clockworkpi os image, just exchange microSD card itself to 128GB SunDisk A2 v30 u3 class disk.(SDXC).

Once I recieved email response from support but no recovery yet with their suggestion.

Maybe I luckyly get paper weight .


Long term I forgot to update.

Clockworkpi team gave me the new PI board and which works well.
My issue is solved.

Thank you all.

The root cause of my trouble is dead the regulator for power management board.
Some of AC charger provided huge in-rush current and it cuased the damage to the regurator.

1 Like

How did you diagnose? I think I might have the same problem, I’ve reflashed the SD card and reseated the display cable but nothing works so far.

Sorry late response.

My case I heard kind of sperk sound when I turned off the system.
So first of all, I doubt power line module.
Luckly clockworkpi team shipped new board for main and cpu, so I could confirm the problem on main board.

Then check the power line route with multimeter and find O302 chip couldn’t generate proper valtage.

I forgot chip spec but order new one then rsolder it.
Now no issue with original board.