Need big help with clockworkpi

ok so i tried updating the os to v0.5 and failed miserably and ended up accidentally deleting the clockwork pie OS all together, i keep trying to download v0.4 to a SD card but nothing is working. every time i try to flash it it fails. if i buy a new development board will it come with a new micro SD with the OS? or is there a way to save my clockwork pi without buying a new development board. im a begninner with tech but i guess messing up is a part of the learning experience. if anyone has any answers please let me know. thank you.

ps if possible i just wanna stay in v0.4 since i hear v0.5 is buggy

You don’t need to buy a new board.
You are probably not flashing the image to the SD card properly. How are you copying it to the SD card? BalenaEtcher is probably the easier way to flash images:

i downloaded that program and tried flashing it there. i clicked the download link. should i use the url download instead of the other one then? also which version do you recommend i upgrade to. 0.4 or 0.5

like the first time i tried doing it got halfway in balena then at the end says it failed. so idk what im doing wrong.

have you unziped the img downloaded?

no but ill try. i also dont remember being able to unzip

if you are on windows , you can use the 7zip, which is a free software , able to extract the clockworkpi os image file

when it done
the file will be about size of 2.5gb

okay and thanks for the advice. good to know this community is alive and friendly :smile:

1 Like

also the size was not 2.5 it was like 7.3 for me and whenever i try putting it on the sd card it just says its too big.

The compressed file should be around 2.5 Gb, uncompressed would be more.

For instance the 0.5 is 1.7Gb compressed with the extension .bz2 when uncompressed is 6.1Gb with the extension .img

To flash you need to use the .img

You could use



You need to select the file, the partition of the sd card (Device on the screenshot) and click write.


You need to select the file, the partition (Device on the screenshot)

Careful selecting partitions to not whipe something else, but dont worry the program wont show hard drives, it should show only external devices.


after i write it to the thing it wont let me access the sd card and asks me to format it and kicks me out if i say no. once i write it am i good to go or is there more steps

Don’t worry! That is normal! You can’t access the SD card unless you are using a Linux machine. It is formatted in a different way that windows and mac doesn’t natively read. (It can with some helper programs)

I think you have successfully flashed, seeing as in your other thread re: the power not turning on, the light at least comes on. That is a good sign!

The next thing, re: 0.5 being buggy. I can assure you that 0.5 is leaps and bounds better, more stable, faster and cleaner than 0.4. It’s basically 0.4 with graphic drivers that actually work. It’s funny. When 0.4 first came out, everyone was nay saying it, saying to stick with 0.3. Everything has its teething problems when they first come out, and unfortunately those are the posts that remain. 0.5 is over 6 months old now, so is quite refined now.

The problems with stability people were having with 0.5 was the upgrade process. Seemingly, unless you upgraded from a clean 0.4 image, it would occasionally fail. I managed to do it fine back when it first came out, even on a heavily modified and upgraded 0.4 image. I strongly believe the majority of the problems people post about come down to user syntax error.

If you’re a beginner, then I highly recommend my custom image I made. since it comes with most things set up for you already, and most of the commonly seen mods pre installed. This way you can avoid a lot of problems with installing things, and then inevitably “breaking” the system, causing frustration with having to reformat.

The operating system is extremely customisable, but uses a very strange system that is VERY finicky. You have to learn to tame the beast! :stuck_out_tongue: I would say that it is not very beginner friendly with regards to customising. That said, it is extremely satisfying once you do get it all down. I spend more time messing with the operating system than actually playing games! One day I’ll just use it as a “toy” :wink:


okay this is very helpful! thank you so much. i will try formatting using your custom image. again thank you so much for taking the time to help me! i will let you guys know if i can successfully do it!

1 Like

just a question. i keep flashing your custom os image and followed the instructions. yet i still cant get it to turn on. also when i try accessing the SD card it wants me to format it.

1 Like

First, lets talk about the whole not turning on thing. Are you using the one I just uploaded today? I actually haven’t tested it myself yet, ie the image. I’ve been… very tired! Haha. So I’ll get onto that to confirm it working soon. But theoretically it should work. I run the exact script to prepare my images every time.

Have you tried my response to your other thread?
I have a theory regarding when it doesn’t turn on. If you try and turn the gameshell on, when there is no SD card in the slot, or a SD card that doesn’t contain a valid bootable image written to it, the gameshell enters a strange “limbo” state where in order to get it working, you need to have it plugged in, and then push the “hidden” reset key, located on the opposite edge to the power button. Give that a go!

Now, onto not being detected when you insert it into your computer.

Yes! This is to do with the header I imported from the stock DEOT OS file to inject into this image file. By default, the newer OS’s mount the /boot partition when inserting it into a non linux machine, in a format readable by both windows and macOS.
The older DEOT OS did not do this, and since no partition that is readable by your computer can be read, your computer immediately assumes that you want to access it, so suggests formatting. Ignore this.
Even if you can access the /boot partition, you’ve only got about 8MB to play with. This is for putting files such as kernels, and other low level boot up things that you probably never need to ever touch.
The reason my image has this is the initial boot image. I wanted to replicate the original DEOT image perfectly, however Gcores haven’t provided any of their sources to be able to do this. So I had to resort to stripping the stock image of the first thing that loads. The problem is, partition table info pertaining to mounting is also fairly early on in the sectors, and very close to the boot up image. I potentially could try and work out exactly which sector the image starts, and just write it there, but then I would also need to make sure that I didn’t overwrite anything else. Since it was all in Hex, trying to decipher it is not something easy to do, so I made a compromise.

okay so i pressed the secret reset key and still nothing. im still troubleshooting though.
lol if all else fails ill just wait until products are restocked. anyone know if i buy another development board, will i get a new micro sd with the os installed like it did when i got my first kit?
no sweat and thank you all for trying your hardest with helping. its really appreciated and im grateful this community is so helpful.
shoot i may just buy a new gameshell all together, but if possible like i questioned with the development board ill do that instead.



Mmm the board shouldn’t be fritzed from just regular use, unless you were physically abusing it. it’s very protected. The fact that the light comes on mean you just need to persevere!
I mentioned it in the other posts, but I’ll reiterate here what I’ve done in the past, after similar scares.


The moral of the story! KEEP PERSEVERING AND YOU CAN DO ANYTHING!! :smiley:

1 Like

i couldn’t agree more! thank you so much for your patience and knowledge. i hope you have a good day or evening where ever you live, i need to sleep after setting this up all day lol.
hope to talk to you guys soon, take care!

BTW 10/10 best and fastest responding guy right here @javelinface
real champ and bro :smiley:


Thank you so very very much! That makes me feel really good. Ahh it’s people like you that make me LOVE seeing people get happy, and get real satisfaction.
Also haha I was up till 4am doing stuff, working on my image! We all know that all nighter feeling too well!
Get some sleep, and enjoy your console!

hint: Don’t do too much on the gameshell just yet! I’m about to do another update tomorrow - just a small one. Might not even apply to you. Just putting making wifi drivers work for one of the kernels. If you don’t know what a kernel is, then DO NOT WORRY! :slight_smile: Chances are, by the time you decide to tinker with Kernels etc, something newer and even better will be out.

1 Like

ill definitely keep that in mind for when i get more knowledge, ive got a long ways to go before i mess with that stuff. lmao

1 Like