PCSX ReARMed for GameShell

I also can’t play pbp games, but in my case it just says unuspported/invalid CD image, does anyone know if I have to turn on any option form the menu or something?

I haven’t been able to get those files functioning yet, i’ll try playing with it more this week when I have time.
For now, the best option is to just find the .bin/.cue file and use those. I’ll post an update on this post if I come across anything useful this week.

Alright, thanks for the reply

I’m getting a little confused of how to get this core to run. Do we download this direct from retroarch or is there a core just for the gameshell.

A Quick Question about cheats here…
I’m using the standalone PCSX for gaming (i love how Menu just opens the menu, instead of backing out of the game entirely) but I cannot open the cheat files like I can using RetroArch.
Any hints for using cheat files with the standalone, please?

have you tried using psxvcd to convert it to bin/cue (not sure if this works though)

you don’t use the ones from retroarch, look up cheat.db or message the discord and i’ll send you it

Thanks. Ill give it a shot tomorrow!

What type of files will this core run.

Nothing I try seems to go more than 20 fps. Added the bios and it seems to be loading correctly, but not exactly what is call playable.

Any ideas how to get it to the point the volume doesn’t sound like it’s going through a propeller?

I seem to get much better results from the standalone pcsx (instructions by hpcodecraft) then trying to run a core through retroarch.

1 Like

Hey man, can I ask you some questions here or via PM? I’ve gotten the ps1 games to run, I’m not seeing a standalone app pop up in the menu. I see the core in retroarch, at one point it was telling me I hadn’t loaded the bios correctly but that has gone away.

The issue: When I run the game I’m getting 26 FPS and it’s extremely choppy. Trying to run crash bandicoot. What’s the reasoning behind this choppiness?

Hey 14thLord, did you ever figure this out? I’m having the same issue!

You download the core from retroarch. Then a Pcsx icon should appear in your retrogames. Then instead of using Retroarch, use the Pcsx emulator which would be inside Retrogames

can you please provide a link?

Post earlier in this topic Aug 2018.

These are the instructions from hpcodecraft

It is a stand alone version, the repo contains a binary as well as a logo and shell script for the launcher.

Install with

cd ~/apps/launcher/Menu/GameShell
git clone https://github.com/cuu/Pcsx.git

You’ll still need a BIOS file though:

mkdir -p ~/apps/launcher/Menu/GameShell/Pcsx/bios

Transfer scph1001.bin bios file to that folder, restart the launcher and you’re done.

To update the binary in case the repo gets updated, do this:

cd ~/apps/launcher/Menu/GameShell/Pcsx
git pull

When starting the emulator for the first time, you’ll want to configure the controls from the emulator menu because they aren’t setup properly yet.

I would check the original post to make sure I’ve copied and pasted all the instructions

1 Like

Edit: I just realized left/right on the D-PAD cycles through the options…yay.

I can’t seem to figure out how to remap ABXY to X, Circle, Square, and Triangle in RetroArch at the PCSX ReARMed core level. I load the core, then go to Controls under the Quick Menu and you would think I could remap the buttons, but the buttons don’t respond. I thought I could manually with the remap file, but it’ll only output what’s different… But since I can’t edit them in the menu, the remap file doesn’t have much to edit.

Any insight would be appreciated!


Also, what’s the Search button used for? Once I press it, a search box pops up, but then it doesn’t take any input. I have to hard reboot to get control back.

Anyone know how to make launchers for games with these standalone emulators. the guide, i found , just works with retroarch emulators.

ths is what i tried for my sh file:


but that not launching it, and i did chmod the file

And the sh file is already in the folder where pcsx is located? If not, you’d have to cd to that directory first.
Also, maybe you’d have to direct to the rom in the same line, but I’m not really familiar with this stuff. ^^’

its not , the sh is in cpi/launcher/menu/gameshell

and pcsx is in cpi/launcher/menu/gameshell/pcsx

Still dont have it working but also would like to know how for picodrive as well.