clockworkpi

PICO-8 crashes when started in "stable 1.25". Tried everything I've seen on here

I bought PICO-8. I used my Windows computer to copy Raspberry Pi version onto my gameshell, specifically into the games folder and the PICO-8 folder. It didn’t work. I tried running it again, actually many times, but all that happens is it sends me to the Gameshell main menu (the menu with Settings, Tiny Cloud, TIC-80, etc.) I tried renaming the file to several different names (for example, changing the 12c2 or sth. like that to 11g, 11g1, and others) like the German guy said to in his YouTube video. I tried copying it to PicoDrive instead, but nothing. I tried reinstalling PICO-8, both on windows and my gameshell. Neither worked. I also tried rebooting my gameshell after installing pico, to no result. What does happen is a folder called carts gets created seemingly wherever I paste the zip file to. And it creates lots of itself, inside itself. Meaning when you click on it, you get another folder called carts, and when you click on that folder another carts folder is there, etc. If I think of anything else I’ve tried I’ll post a reply to this or edit this post if possible. Thank you for helping me.
EDIT #1: I also tried viewing the zip file in DinguxCommander or sth. like that and it’s either blank or the screen whites out. If it helps, my Windows computer lacks OpenGL, whatever that is, but I didn’t figure that out by using my gameshell.

Just confirming, you’re putting the file named pico-8_0.1.12c2_raspi.zip in the ~/games/PICO-8 directory?
Mine is a 6.1MB file. I bought it in a humble bundle once upon a time. Is yours a legit one?
Also try and run the PICO-8 app without anything in the games directory. I find that the first time, it will just give a black screen, then return to the launcher; possibly initialising itself. Afterwards, run it again. It should have a screen telling you to download the pick 8 files. Transfer the files after this, then run it again.

Here’s a screen cap of where I have it placed, and the expected file output.

Try running it without anything in the games directory, meaning move all the files in the games folder out of it? I bought mine from lexaloffle.

1 Like

Thank you sir, it worked!

1 Like

Although there are still a ton of those “carts” files I typed about in the original post

1 Like

Glad it worked.
As for the folders, they’re probably leftover from your erroneous installation.
The only files needed in that directory are the ones from my screen shot.
If you know how to use Linux a bit, do a recursive remove on the directory.

rm -r ~/games/PICO-8/carts

I don’t know what your carts folder name looks like, but just letting you know it’s case sensitive, so change the name in the command as required.
If it doesn’t work, try prefacing it with sudo. I generally am not a fan of overusing the sudo command, but that’s just me.
It kind of sounds like it’s not a folder within a folder, but symbolically linking to itself.

Hi javelin, thank you so much for the help a few days ago. I was wondering if I could post a discussion of comparison between PICO-8, TIC-80, Love2D, and any other game development programs that work on gameshell on here. Do you know if I am allowed to do that here? If you’re not a moderator here then could you point me to one? Thank you!

2 Likes

Not a mod, but I absolutely think you should post this comparison. I’m super interested in reading about this.

1 Like

Mod here, absolutely! In this community we are about open discussion and it will be nice to have comparisons.

The only restrictions are thowards hateful posts, copyright infringements and so on, you get the point, everything else is welcome :slight_smile:

1 Like

Not a mod; just a user like you. Everyone helps each other, and keeps things happy. It was mentioned in a post somewhere that this forum was one where the creators didn’t want to have moderators as people with more of a voice than others, and for the forums to be entirely community driven. The mods keep things tidy and safe. Look for the little shield icon next to people’s names. :slight_smile:

For your info, the moderators are @aewens, @Godzil, @micro007, and @petrakis. (In alphabetical order)

There are also leaders, including @Veronica, @yong, and @hal. They’re the ones with the inside scoop, and customer service know how.

You can also find who are the people with « power » on the forum from the shield logo next to their forum name as Petrakis and I do have

Sorry, I don’t already have one. I was thinking of posting a “What’s the difference?” type of post.

Hi javelin, how does one start Love2D? I’ve read on here it comes pre-installed on all the Gameshells, but where is it? If one has to go online to download it, though, which version(s) work on the Gameshell? Do I send it from a computer to a Gameshell, or can I download it without a traditional computer? Thank you so much for all the help so far. I hope I’m not annoying you with all these questions these past few days.

The love2d engine is installed and ready to go. You just need to provide games.

The good news is, hopefully with the new warehouse system in 0.5, perhaps soon you will be able to download love games directly from an online gameshell. Once someone puts up a repository that is.

For now, you’ve got it! Just drag and drop the love files into the ~/games/love2d directory.
Here’s an example of what is in mine. It should just be *.love files.


The 909 game should be pre installed already.
As for compatibility, I actually have only tried things specifically written for the gameshell. This will take into consideration resolution, controls and other things inherently needed due to the hardware constraints.

But hey! If you know of anything else that isn’t already on the forums, post it up! Share the … love. gets shot

Just to keep things neat, and on topic, here’s a link to basically the same topic, cross posted in a new thread. Probably best to continue discussion on this here:

Apologies for replying to this one first. It was in a thread I was following, so I saw it before the other one.

Thank you javelin!!! And no need to apologize, I should be the one apologizing to you for asking so many questions!

1 Like