Pros / cons of upgrading 4G firmware?

I have read the wiki

It is clear we have a choice between then 9001 and the 9011 firmwares and that these use two very different approaches to accessing the modem.

I see that 9001 uses nmcli based approach.
I see that 9011 uses an rndis based approach.

There is a warning in the wiki that if one moves to 9011 it is impossible to move back and that nmcli might (will not?) work anymore.

  1. does anyone have a strong opinion on which to use?
  2. if so why?
  3. anyone who moved to 9011 do you regret it?

I didn’t update the firmware, I didn’t see any necessary.

1 Like

I’ll not upgrade the modem, for:

  1. I prefer that the 4G module completely manageable on the host, exposing every possible function.
  2. If the modem is not manageable via ModemManager(MM) after upgrade, will I be able to make a call with it? Or will the GNSS function work? I haven’t look into it, but I doubt it.
  3. I have experience of using a modem with MM, and I’m fine with it.
  4. It looks like MM has support for this series of modems and there’s no need to switch the firmware, unless you really want to avoid some configurations.
  5. There’s no known way back.

BTW, instead of “firmware upgrade”, I think “firmware switch” better describes the operation.

1 Like

I agree, that’s why i asked, it seemed more of a switch than an upgrade. different != better , and i know i dindn’t know enough to evaluate what i should do (and the wiki is lacking in pros/cons) thank for taking the time, i appreciate it

well as i don’t have network manager running i seem to have run into the issue described here

Unable to connect 4g (Network Manager not running) - uConsole - clockworkpi

basically i have no modem, and usb0 when i ip a, the SIM is reporting ok

did you sudo update and it broke? or it just wasn’t working… Questionable support with MM will make me hesitant to “switch firmware”… but by time i actually recieve mine… it will problably all be worked out…

I updated with apt before I ever tried the modem.
One of two things fixed my issue detecting the modem

  1. Switching back to network manager
  2. restarting ModemManager after running the modem enable command

Still havent managed to get the SIM to activate… not sure if it my APN settings or what…

ModemManager looks pretty good and well documented.

I hope this info can help you track down and build the connection activation string.

yes indeed, i have read the modem manager docs and installed the gui sudo apt install modem-manager-gui - the issue is the SIM never registers on the network - my issue isn’t how to use modem manager - its if the APN settings given by the network provider work with it… i suspect there is something missing… i may need to put the SIM in a real phone first…

also note those instructions are very misleading, nothing needs to be installed with snap and modem-manager is already installed on the device image

yea, i mean… was hoping you would run

sudo modem-manager.mmcli -m 0

and look at what it says about your sim… if its locked… got any signal…

Sorry, i missed you saying you are using the included image…

If you tried the string and it fails… i would call your cell provider and make sure they allow your device to be provisions on their network… they may have to pass it to engineering and request a device exemption… in the US… verizon didn’t let me… so i switched to t-mobile… but that was a linux phone… not a 4g modem…

good luck though.

i posted this a couple of days ago, thought it redundant to post the same detail here… i think it will have the details you were looking for (aka i already read the manuals 3 days ago :stuck_out_tongue: )
Help with 4G card - can’t get any modem to show up - uConsole - clockworkpi

I even edited the enable script to restart the ModemManager service as that is needed EVERY time and not documented…

Even a simple connect is not working - so its either the APN details are wrong or they are only allowing iOS and Android devices like you say.