RetroArch Megathread

How can I set the directory ? I mean how can i even change the line from defualt to something else?

You press the OK button and it asks you to navigate to the dir

Thank you. Now I only have to figure out how to set up new directories. Great work anyways

You rock. Tnx! :slight_smile:

Could I get a quick rundown on how to SSH with the GS? I downloaded Filezilla, but i’m drawing a blank here.

1 Like

Hmm. My system freezes on the “make -j4” command. Got everything else done though. Any suggestions?

1 Like

Your CPI freezes? it shouldn’t I haven’t seen that at least.

The Gameshell freezes, yes. Had to hold the power down for awhile before it finally shut off, and now it can’t read any wifi networks. A very strange turn of events. lol

Edit: Now it just boots to a white screen. Well dangit.

Edit edit: Works again

Weird, these commands are completely regular linux commands, nothing too fancy so it shouldn’t cause any issues.
Just good 'ol regular build instructions.

Yeah I have no idea. Seems simple enough. It’s done it twice so far. I’ll try it again I guess.

Ok. It keeps stopping on this line.

`CXX deps/glslang/glslang/SPIRV/SPVRemapper.cpp`

I’ve also gotten ‘Virtual memory exhausted’

Are you sure it’s frozen? maybe it’s just taking a while.
Also, did you do --disable-vulkan? in the configure script?

I let it sit for about 30 minutes the first time. I could of sworn I did the disable vulkan. I guess it wouldn’t hurt to input it again, however.

I disconfigured my Button Layout accidentily. How i can set it to default?
The Problem: I not can use the “Enter” button to navigate through the menu. :frowning:

I did the same thing earlier today! I had to ssh in, and manually edit the config file ( ssh in then enter: nano .config/retroarch/retroarch.cfg ). It was a slow process, and I bet there is a quicker fix, but that is how I solved it.

You can always remove ~/.config/retroarch/retroarch.cfg

I did the same thing earlier today! I had to ssh in, and manually edit the config file ( ssh in then enter: nano .config/retroarch/retroarch.cfg ). It was a slow process, and I bet there is a quicker fix, but that is how I solved it.

Sadly no because they made changes to the defaults so it suits the rest of their launcher better.

You can always revert the config by downloading this: https://raw.githubusercontent.com/clockworkpi/GameShellDocs/master/retroarch.cfg

And moving it to ~/.config/retroarch/retroarch.cfg

2 Likes

Sigh. I feel like i’m having the most issues here. Everything finally went through but now RetroArch just loads to a black screen then i’m dumped back to the Gameshell OS. Any way to just start over?

Can you paste the build log?
Use the preformatted text button to enclose it so it’s easy to read.

I apologize but I am very new to editing things in SSH. I am using PuTTY at the moment. How do I find the build log?