RetroArch Megathread

retroarch
howto

#22

How can I set the directory ? I mean how can i even change the line from defualt to something else?


#23

You press the OK button and it asks you to navigate to the dir


#24

Thank you. Now I only have to figure out how to set up new directories. Great work anyways


#25

You rock. Tnx! :slight_smile:


#26

Could I get a quick rundown on how to SSH with the GS? I downloaded Filezilla, but i’m drawing a blank here.


#27

#28

Hmm. My system freezes on the “make -j4” command. Got everything else done though. Any suggestions?


#29

Your CPI freezes? it shouldn’t I haven’t seen that at least.


#30

The Gameshell freezes, yes. Had to hold the power down for awhile before it finally shut off, and now it can’t read any wifi networks. A very strange turn of events. lol

Edit: Now it just boots to a white screen. Well dangit.

Edit edit: Works again


#31

Weird, these commands are completely regular linux commands, nothing too fancy so it shouldn’t cause any issues.
Just good 'ol regular build instructions.


#32

Yeah I have no idea. Seems simple enough. It’s done it twice so far. I’ll try it again I guess.


#33

Ok. It keeps stopping on this line.

`CXX deps/glslang/glslang/SPIRV/SPVRemapper.cpp`

I’ve also gotten ‘Virtual memory exhausted’


#34

Are you sure it’s frozen? maybe it’s just taking a while.
Also, did you do --disable-vulkan? in the configure script?


#35

I let it sit for about 30 minutes the first time. I could of sworn I did the disable vulkan. I guess it wouldn’t hurt to input it again, however.


#36

I disconfigured my Button Layout accidentily. How i can set it to default?
The Problem: I not can use the “Enter” button to navigate through the menu. :frowning:


#37

I did the same thing earlier today! I had to ssh in, and manually edit the config file ( ssh in then enter: nano .config/retroarch/retroarch.cfg ). It was a slow process, and I bet there is a quicker fix, but that is how I solved it.


#38

You can always remove ~/.config/retroarch/retroarch.cfg

I did the same thing earlier today! I had to ssh in, and manually edit the config file ( ssh in then enter: nano .config/retroarch/retroarch.cfg ). It was a slow process, and I bet there is a quicker fix, but that is how I solved it.

Sadly no because they made changes to the defaults so it suits the rest of their launcher better.

You can always revert the config by downloading this: https://raw.githubusercontent.com/clockworkpi/GameShellDocs/master/retroarch.cfg

And moving it to ~/.config/retroarch/retroarch.cfg


#39

Sigh. I feel like i’m having the most issues here. Everything finally went through but now RetroArch just loads to a black screen then i’m dumped back to the Gameshell OS. Any way to just start over?


#40

Can you paste the build log?
Use the preformatted text button to enclose it so it’s easy to read.


#41

I apologize but I am very new to editing things in SSH. I am using PuTTY at the moment. How do I find the build log?