RetroArch Megathread

Hello All,
I have some issue, when I try to use video filter retroarch stop working and close without saving.
Also when I force to use the filter by modifiy manually the retroarch.cfg the filter isn’t use.
Have you somes ideas?
Thank you :slight_smile:

The default installation has a few things omitted in the config/make process. This was no doubt a relic of the older days when we hadn’t gotten the Lima drivers to really behave, and it simply wasn’t worth using filters.
They use a lot of resources and basically slow things down a lot. That said, with recent driver development on the gameshell front, things may well work better!
Have a look into upgrading the kernel, Lima/Mesa drivers and then recompiling Retroarch from scratch.

I’ve made a custom image with all of that done, if you just want to test it. Using the image, I just ran a few random filters on a snes core in Retroarch, running castlevania V. Seems to work fine with no problems, slow downs or crashes. This is using the Lima drivers.

Hello,
Ok thank I’m going to explore that.
When you talk about your custom image it’s the D.E.O.T?

1 Like

Yup, that’s the one. :slight_smile: just trying to do the community a good deed, putting together the more cumbersome scripts that seem to cause the most user problems.

I assume you can SSH into your GS already. no and how?

Flashed 0.4 OS image to SD and tried to run libretro vice (c64) in RetroArch but it just loads for few seconds and then reverts back to Gameshell UX… it worked earlier (like several months ago) but now I wanted to start “fresh” and not sure what is going on… anyone else having the same … wondering if this is some version issue or something else…

all the games I tried worked just fine

hi, thanks for the info i will take a look. thank you.

Never mind :slight_smile: Just flashed 0.5. Everything works now again.

1 Like

Hi! Seems I can’t compile using make -j4
It hangs indefinitely and then fails with
g++: fatal error: Killed signal terminated program cc1plus
compilation terminated.
Makefile:220: recipe for target ‘obj-unix/release/ui/drivers/ui_qt.o’ failed
make: *** [obj-unix/release/ui/drivers/ui_qt.o] Error 1
make: *** Waiting for unfinished jobs…
Any idea anyone ?
Probably not important but it fails on CXX ui/drivers/qt/ui_qt_msg_window.cpp.
I tried several times and still the same result. I also tried with make -j3 but it fails now on CXX ui/drivers/qt/coreoptionsdialog.cpp

Hullo! Welcome to the forums!

I actually go as far as going down to -j2.
You probably know it, but it’s just referring to the number of jobs.
It’s funny that you’re not hanging on the same file that I see most people getting stuck on. Just a small observation.

The good news is, whenever it hangs for me, I can just terminate the operation, modify the number of jobs, and then resume from where I left off without any adverse effects.

I built retroarch about 5 times today using two jobs. It might take longer, but at least there’s the assurance it’s not going to hang, so you can go and make a cake, or do your ironing or something.

Also, you probably already worked it out, but this guide is probably the grand father of the retroarch addition to the gameshell. The current retroarch is installed in the ˜/.config/retroarch directory.

Thanks! I tried with -j2 and it’s slow but it seems to work! :slight_smile:

1 Like

you could try create a swap file before launching the make -j4

1 Like

@lasvegas just made this great post covering exactly that! Cheers for that again.
[SWAP] Simple method to install a Swap file

Hi

How did you get FBA to work?
Do you have a tutorial - if at all possible?

I got MAME to work perfectly, BUT the odd rom would exit back to launcher - even when it’s a MAME romset rom.

Thanks

That would no doubt be mainly neo geo Roms like Metal Slug I take it.
What version of the clock work OS are you using? And what version of Retroarch? Just so I know where to come from.

One quick way to do it is to go into Retroarch’s online updater, go into core updater and download the file named “fbneo_libretro.so”. (Get fbneo - it’s probably more what you want)

Now. The above is assuming that your Retroarch is configured to download from the correct buildbot URL. It should be: https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/
This will give you access to the cores that are better suited to the gameshell. If you don’t have it set to this, it doesn’t matter too much. Possibly not all cores are written to utilise all instructions.

The next assumption is that you know where your Retroarch has its core installation location specified as. From memory it is probably in ~/apps/emulators by default. I personally change it, preferring of only populate the aforementioned directory with standalone emulators.

Next is to have the correct rom set for the correct core. The usual grey area applies here, so your best bet is to google the core you’re using, and find out what romset works with it and where to get it. Once you have that, it might be a good idea to have different rom sets in different directories.

After we have the above sorted, you can go ahead and make an action.config file to use FBA like you would Mame. You’ll need go specify where to find the Roms, where your fbneo_libretro.so is located, specify what you want it to read zip files since that’s what the Roms will be, and provide the Retroarch -L parameter under the launcher section. (And of course give the folder a friendly identifiable name, and a matching icon)

Haha, thanks Peter.

We spoke about this in another post - after getting MAME to work.
Going to give this a try this evening.

Oh, and running your Custom D.E.O.T. V0.5 :slight_smile:

Oh neat! That will make sending you configuration files that will get it working super easy - I’ll just send my own versions.

I’ll do that tomorrow however! I’ve been staying up too late recently… doing gameshell tinkering!

For now, try and source some compatible Roms. :slight_smile:

Right! So since you’re using my firmware, I know what your directory structure is.

First, make a directory called FBA within your ~/games directory, and transfer your Roms that are for FBNeo here. Just a selection, unless you like taking up 20GB of superfluous space!

Next, make a directory in the ~/apps/Menu/20_Retro\ Games/ called something like 11_FBA. It doesn’t really matter. The number just determines that it will be adjacent to the existing Mame folder.

Next, make a file called action.config inside this directory and paste this in:

ROM=/home/cpi/games/FBA
ROM_SO=/home/cpi/.config/retroarch/cores/fbneo_libretro.so
EXT=zip
LAUNCHER=retroarch -L
TITLE=FBA Roms
EXCLUDE=neogeo.zip
SO_URL=https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/fbneo_libretro.so.zip

This is applicable for my custom OS. If anyone is using this for another version, simply modify the ROM_SO line to indicate where you would like it installed.

You shouldn’t need to download the core via the Retroarch online updater, since this action.config contains a SO_URL pointing you to the same file.

From memory, my latest firmware should have a custom icon for FBA already in the skin file. I could be mistaken. If not, just go to ~/skins/DEOT/Menu/GameShell/20_Retro\ Games/ and put a file called FBA.png in that directory that you want the folder to look like. Like I said, I think I included one with the latest version. Otherwise I’ve also uploaded just the skin here (I think the FBA icon was included there?? I’ll find out when I get home from work.)

Anyway hopefully that was easy enough to follow. If not, I’ll write out a script to automate it all for you. :slight_smile:

1 Like