Risc-v operating system does not update

When I run an ‘apt-get update’ on my system, it says ‘conflicting distribution’ in release expected devel but got kinetic.

I don’t know if this is because I am running ipv6, but the system won’t updaate.


chose Y did not work?

I edited my sources.list from dev to jammy to make sure I am up to date before any OS release upgrade

I had a similar error just recently, running apt upgrade -y fixed it.

Notice for apt upgrade:

apt upgrade on R01 os will mess up the content of extlinux.conf
lead the boot failed

so when this happens

mount the sd card(with R01 os) on a PC (like Linux )

then go into the boot partition of the sd card

you will see


replace extlinux.conf with extlinux.conf.cpi.bak

the extlinux.conf.cpi.bak is for this kind of situation



I am following this advice to edit the boot partition of the sd

I have the sd card in my Linux laptop

I have found the _/boot

In it,

I see extlinux.conf which appears to be a text file which I can read, with Mac addresses and suchlike

I can see extlinux.conf.cpi.bak which I can open with vim

So I am going to cp the back up to the file name of the .conf file then sticking the sd in my dev term