clockworkpi

Rise of the Triads for Linux Launcher Script Issue

I have a weird issue right now. I installed Rise of the Triads for Linux and everything works well, at least better than with DosBox. But I can’t manage to create a launcher script for it. The only way I can launch it right now is through the file manager. Any Idea?

What sould I write in my ROTT.sh file?

The file is in: /home/cpi/rott-1.1.2/rott/rott

Shouldn’t ROTT.sh look like this:
cd /home/cpi/rott-1.1.2/rott
./rott

where you put the ROTT.sh
and have you chmod +x ROTT.sh

My ROTT.sh is in the same place all my other launcher are for this type of games.
Yes I did chmod +x

I tried:
/home/cpi/rott-1.1.2/rott/rott no luck

I tried renaming the folder of Rott. No luck

Thing is, it work when I browse to the file with the file manager and execute it directly. Weird!

In the terminal I get:
Rise of the Triad Startup Version 1.4
Commercial Version
Z_INIT: 8950000 bytes
IN_Startup: Mouse Present
Error, Could not find User file ‘DARKWAR.WAD’, ignoring fileError, Could not find User file ‘REMOTE1.RTS’, ignoring fileW_InitFiles: no files found Episode = 0
Area = 1

When I launch through the file manager it works and all my game files are there by the way, but as soon as I try through a launch script it fail like the message above. Where are my gamefiles supposed to be?

Ok so I found a solution.

Install Rise of the Triad like this:

sudo apt-get install build-essential libsdl1.2-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-console-dev libsdl-mixer1.2-dev libsdl-net1.2-dev

sudo apt-get install rott

sudo mkdir -p /usr/share/games/rott/

sudo update-alternatives --config rott (select 1)

Then buy ROTT - Dark War from steam or use the copy you have.
Copy all the files to /usr/share/games/rott/
Create a launcher script ex. Rott.sh
Write only rott in it

Launch a first time and you will get an error message about the resolution.
Quit the game and go to .rott (in /home/cpi), go into darkwar and edit the file config.rot and chage the resolution to 320x240.

Bingo!