clockworkpi

Run retro games in native resolution

All emulators run full screen by default. I notice when I press Menu in gpSP+, the game shows native resolution while showing the emulator. The text looks much more crisp.

How can I configure emulators to run retro games in their native resolution?

1 Like

I managed to find how to do it for cores installed in RetroArch. Just go to RetroArch Settings->Video->Integer Scale, change OFF to ON. All the games will now play in native resolution.

Note this setting doesn’t apply to standalone emulators (for obvious reasons). So it doesn’t work for gpSP+. The pre-installed GPSP core doesn’t work out of box. Need to follow this thread to get it work: Working gPSP file link

To save you time, I summarize the steps here.

  1. Download gpsp_libretro.so here: https://www.dropbox.com/sh/dab0s0m7bz344vn/AAC6QSju8jzb-YUxZrs_3EZga?dl=0
  2. drag the .so file into “/home/cpi/apps/emulators” and into “/home/cpi/.config/retroarch/cores”
  3. FInd gba_bios.bin on Google.
  4. Put it in /home/cpi/apps/emulators/bios
2 Likes