Sound is no sync with display

Hi, i received my gameshell today and everything is fine.

Except that anything i run, nes game, Cave Story sound is 1 second late than the display…

Anyone having this problem or can help me ?

Forgot to mention that FreeDM is ok, sound is sync.

Just go to your retroarch>mainmenu>setting >audio>AUDIOLATENCY> bring it down to 120ms
Resample quality to lowest

Then hold shift and menu x 2 times
Go to configuration
Save current configuration.

Should fix the problem


Ok thank you very much i’ll give it a try !

Oh yeah it works thank you very much ! Why this isnt that way out of the box if the hw can’t handle it ?

Well thanks again !